aboutsummaryrefslogtreecommitdiffstats
path: root/main/acl/busybox-gzip.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-01 10:12:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-01 10:14:11 +0000
commitcfd84b4e8ece29495d5a08d41320633430147ace (patch)
treead1bbe416b6799c6eaf59db10f5355beaf101bc2 /main/acl/busybox-gzip.patch
parenta4bb590c51eaff97ac3f63703f4a48e1e5311bbf (diff)
main/acl: fix building with busybox gzip
we want keep build deps down to simplify bootstrapping
Diffstat (limited to 'main/acl/busybox-gzip.patch')
-rw-r--r--main/acl/busybox-gzip.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/acl/busybox-gzip.patch b/main/acl/busybox-gzip.patch
new file mode 100644
index 00000000000..e443fc495ce
--- /dev/null
+++ b/main/acl/busybox-gzip.patch
@@ -0,0 +1,26 @@
+diff --git a/doc/Makefile b/doc/Makefile
+index a08e403..d739781 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -28,7 +28,7 @@ default: CHANGES.gz
+ include $(BUILDRULES)
+
+ CHANGES.gz:
+- $(ZIP) --best -c < CHANGES > $@
++ $(ZIP) -c < CHANGES > $@
+
+ install: default
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+diff --git a/include/buildmacros b/include/buildmacros
+index 9e81bb8..b33e148 100644
+--- a/include/buildmacros
++++ b/include/buildmacros
+@@ -139,7 +139,7 @@ endif
+ MAN_MAKERULE = \
+ @for f in *.[12345678] ""; do \
+ if test ! -z "$$f"; then \
+- $(ZIP) --best -c < $$f > $$f.gz; \
++ $(ZIP) -c < $$f > $$f.gz; \
+ fi; \
+ done
+