aboutsummaryrefslogtreecommitdiffstats
path: root/main/apg/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-25 13:21:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-25 13:21:32 +0000
commitdd630368960fa0e70d80df21d119ebc099ecb4d0 (patch)
tree631f1d63f98425986f9dc529aee8b01a344f824d /main/apg/APKBUILD
parent9c8fe408521a81e392824efbac0fb87acfbba0ad (diff)
main/apg: new aport
Automated Password Generator http://www.adel.nursat.kz/apg/index.shtml
Diffstat (limited to 'main/apg/APKBUILD')
-rw-r--r--main/apg/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/apg/APKBUILD b/main/apg/APKBUILD
new file mode 100644
index 00000000000..98d41665a69
--- /dev/null
+++ b/main/apg/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=apg
+pkgver=2.2.3
+pkgrel=0
+pkgdesc="Automated Password Generator."
+url="http://www.adel.nursat.kz/apg/index.shtml"
+license="custom"
+subpackages="$pkgname-doc"
+depends=
+makedepends=""
+source="http://www.adel.nursat.kz/apg/download/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ sed -i 's:^#\(CS_LIBS = -lnsl\)$:\1:' Makefile
+ make || return 1
+ for i in apg apgbfm; do
+ install -D -m755 $i "$pkgdir"/usr/bin/$i
+ install -D -m644 doc/man/$i.1 "$pkgdir"/usr/man/man1/$i.1
+ done
+ install -D -m 644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="3b3fc4f11e90635519fe627c1137c9ac apg-2.2.3.tar.gz"