aboutsummaryrefslogtreecommitdiffstats
path: root/main/apg/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-30 12:45:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-31 12:07:13 +0000
commit322938bb2fd5009b2d74c20888f027f11661fd28 (patch)
treeff35c56a0858ca71af91023d896b56c2ac797784 /main/apg/APKBUILD
parenta792b0d478cdafe201a6f8235093151ce47c98f8 (diff)
main/apg: specify license and update layout
Diffstat (limited to 'main/apg/APKBUILD')
-rw-r--r--main/apg/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/main/apg/APKBUILD b/main/apg/APKBUILD
index afbee15d540..860270b2784 100644
--- a/main/apg/APKBUILD
+++ b/main/apg/APKBUILD
@@ -1,25 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apg
pkgver=2.2.3
-pkgrel=2
+pkgrel=3
pkgdesc="Automated Password Generator."
url="http://www.adel.nursat.kz/apg/index.shtml"
arch="all"
-license="custom"
-subpackages="$pkgname-doc"
-depends=
+license="BSD"
+depends=""
makedepends=""
+subpackages="$pkgname-doc"
source="http://www.adel.nursat.kz/apg/download/$pkgname-$pkgver.tar.gz"
-build ()
-{
- cd "$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
sed -i 's:^#\(CS_LIBS = -lnsl\)$:\1:' Makefile
make || return 1
+}
+
+package() {
+ cd "$_builddir"
for i in apg apgbfm; do
install -D -m755 $i "$pkgdir"/usr/bin/$i
install -D -m644 doc/man/$i.1 "$pkgdir"/usr/man/man1/$i.1
done
install -D -m 644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
+
md5sums="3b3fc4f11e90635519fe627c1137c9ac apg-2.2.3.tar.gz"