aboutsummaryrefslogtreecommitdiffstats
path: root/main/api-sanity-checker/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-30 13:12:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-31 12:07:13 +0000
commite9edbe15644bb974ed56921b01eba5b0437a0c89 (patch)
tree6f990bb95b812e9811bc12d07fda048579b0a60f /main/api-sanity-checker/APKBUILD
parentc0c614a1f74fe0d55613a824e12cc3756b22da73 (diff)
main/api-sanity-checker: upgrade to 1.98.6
Diffstat (limited to 'main/api-sanity-checker/APKBUILD')
-rw-r--r--main/api-sanity-checker/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/main/api-sanity-checker/APKBUILD b/main/api-sanity-checker/APKBUILD
index 140dd0f8c38..30da07515d9 100644
--- a/main/api-sanity-checker/APKBUILD
+++ b/main/api-sanity-checker/APKBUILD
@@ -1,20 +1,20 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=api-sanity-checker
-pkgver=1.12.10
+pkgver=1.98.6
pkgrel=0
-pkgdesc="tool for creating automated test suites from any set of C sources"
+pkgdesc="A tool for creating automated test suites from any set of C sources"
url="http://ispras.linuxbase.org/index.php/API_Sanity_Autotest"
arch="noarch"
-license="GPL"
+license="LGPL2+"
depends="perl build-base"
depends_dev=""
-makedepends="$depends_dev"
+makedepends="$depends_dev perl-dev abi-compliance-checker"
install=""
subpackages=""
-source="https://github.com/downloads/lvc/api-sanity-checker/api-sanity-checker-1.12.10.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lvc/api-sanity-checker/archive/$pkgver.tar.gz"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
+_builddir="${srcdir}"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
@@ -25,10 +25,17 @@ prepare() {
done
}
+build() {
+ cd "$_builddir"
+ return 0
+}
+
package() {
cd "$_builddir"
mkdir -p "$pkgdir"/usr
perl Makefile.pl -install --prefix=/usr --destdir="$pkgdir" || return 1
}
-md5sums="b59e573c42a7e7398203b9323889bdb5 api-sanity-checker-1.12.10.tar.gz"
+md5sums="6bca8e90f73a14283a4a85b788d86197 api-sanity-checker-1.98.6.tar.gz"
+sha256sums="5b6fb42d4006702da82f569efcd328fea78c48063c6f2b3d677ec15aabd233c9 api-sanity-checker-1.98.6.tar.gz"
+sha512sums="fcb8c1a3d1c477c2824ffca62680036634393fac15a3e6bf153d2f3e77c105a423ae7c698fedabf0ef06372e85b5001903172aa27ff94bd0d69eb9dfed4a6568 api-sanity-checker-1.98.6.tar.gz"