aboutsummaryrefslogtreecommitdiffstats
path: root/main/apk-tools/APKBUILD
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2021-09-25 02:12:18 -0600
committerAriadne Conill <ariadne@dereferenced.org>2021-09-25 02:13:49 -0600
commit1ac3c1bb29eeff083c621cf6b27ad12ab93cb73a (patch)
treef186e6c13789117821b0a29a4bc0961142f56408 /main/apk-tools/APKBUILD
parentb84c586011a4f76bdfd62afb60ff2356b6a4161d (diff)
downloadaports-1ac3c1bb29eeff083c621cf6b27ad12ab93cb73a.tar.gz
aports-1ac3c1bb29eeff083c621cf6b27ad12ab93cb73a.tar.bz2
aports-1ac3c1bb29eeff083c621cf6b27ad12ab93cb73a.tar.xz
main/apk-tools: explicitly depend on ca-certificates-bundle
A side effect of the OpenSSL migration has been the discovery that ca-certificates-bundle was installed as a side effect, rather than being an explicit runtime dependency of apk-tools. However, it is needed for validating https connections.
Diffstat (limited to 'main/apk-tools/APKBUILD')
-rw-r--r--main/apk-tools/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/apk-tools/APKBUILD b/main/apk-tools/APKBUILD
index e7b468599c..6bd813c552 100644
--- a/main/apk-tools/APKBUILD
+++ b/main/apk-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.12.7
-pkgrel=2
+pkgrel=3
pkgdesc="Alpine Package Keeper - package manager for alpine"
arch="all"
url="https://gitlab.alpinelinux.org/alpine/apk-tools"
@@ -18,6 +18,9 @@ if [ "$CBUILD" = "$CHOST" ]; then
_lua="lua5.3"
subpackages="$subpackages $_lua-apk:luaapk"
makedepends="$makedepends $_lua-dev"
+
+ # ca-certificates-bundle needed for https certificate validation
+ depends="$depends ca-certificates-bundle"
fi
source="https://gitlab.alpinelinux.org/alpine/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz
_apk