aboutsummaryrefslogtreecommitdiffstats
path: root/main/argp-standalone
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-06-11 07:12:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-11 07:13:16 +0000
commit38b1d68577858507f8b3e503deb1076fd38b86fc (patch)
tree3963ef2c9fdce898ff87812b46e96a7b25c6cda6 /main/argp-standalone
parent358126c981e2f0bbc86566d00909963ebfaf6c63 (diff)
main/argp-standalone: gcc5 build fix
Diffstat (limited to 'main/argp-standalone')
-rw-r--r--main/argp-standalone/APKBUILD18
-rw-r--r--main/argp-standalone/gnu89-inline.patch22
2 files changed, 36 insertions, 4 deletions
diff --git a/main/argp-standalone/APKBUILD b/main/argp-standalone/APKBUILD
index 5ace24ce0cc..316369fd461 100644
--- a/main/argp-standalone/APKBUILD
+++ b/main/argp-standalone/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=argp-standalone
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Hierarchial argument parsing library broken out from glibc"
url="http://www.lysator.liu.se/~nisse/misc/"
[ "$ALPINE_LIBC" != "eglibc" ] && arch="all"
@@ -13,7 +13,9 @@ makedepends="$depends_dev"
install=""
subpackages=""
source="http://www.lysator.liu.se/~nisse/misc/$pkgname-$pkgver.tar.gz
- 001-throw-in-funcdef.patch"
+ 001-throw-in-funcdef.patch
+ gnu89-inline.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -24,6 +26,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ autoreconf -vif || return 1
}
build() {
@@ -33,7 +36,7 @@ build() {
--host=$CHOST \
--prefix=/usr \
|| return 1
- make || return 1
+ make && make check || return 1
}
package() {
@@ -43,4 +46,11 @@ package() {
}
md5sums="720704bac078d067111b32444e24ba69 argp-standalone-1.3.tar.gz
-05ba8faf86b1f320127119e9bfc76d1a 001-throw-in-funcdef.patch"
+05ba8faf86b1f320127119e9bfc76d1a 001-throw-in-funcdef.patch
+26557436fa85068f499120f573b05b17 gnu89-inline.patch"
+sha256sums="dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be argp-standalone-1.3.tar.gz
+46b9b6c8dba584694ae9fc17c5fa301056500128f1f0c548360574afe6b3a184 001-throw-in-funcdef.patch
+155dedc1a8fa5f53ee65d875458a00a9a87f8d97d73aea6779aa8d1595191d0e gnu89-inline.patch"
+sha512sums="58c3feb8852b90248fff39e49b5019bd0dcf646790c3eaf70c3262eb81dda31a61dc0a45963c7b4a010e80fc14b37288dcb3b3ef48d02f2d33dd72c1c62e62d9 argp-standalone-1.3.tar.gz
+5e4cdeeb16e6a4fb46a00ab95f3da9276ee554eec00bb2a05da7467961234ba3f9a630aafa7ceb5feb429a84ece8bf03b869fa996b86468f4716935a914c79a4 001-throw-in-funcdef.patch
+69f1d8a4fcd542346f98bc1fb7151db748483fc2f331c8c35114e0891d867b41c603ddaa5f3130aaaf1c640e02c51ac71cee71b62c09301b146812e9059e9ade gnu89-inline.patch"
diff --git a/main/argp-standalone/gnu89-inline.patch b/main/argp-standalone/gnu89-inline.patch
new file mode 100644
index 00000000000..71978eba585
--- /dev/null
+++ b/main/argp-standalone/gnu89-inline.patch
@@ -0,0 +1,22 @@
+diff --git a/configure.ac b/configure.ac
+index 4658839..09f0267 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,16 +79,10 @@ AC_CHECK_DECLS([program_invocation_name, program_invocation_short_name],
+
+ # Set these flags *last*, or else the test programs won't compile
+ if test x$GCC = xyes ; then
+- # Using -ggdb3 makes (some versions of) Redhat's gcc-2.96 dump core
+- if "$CC" --version | grep '^2\.96$' 1>/dev/null 2>&1; then
+- true
+- else
+- CFLAGS="$CFLAGS -ggdb3"
+- fi
+ CFLAGS="$CFLAGS -Wall -W \
+ -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes \
+ -Waggregate-return \
+- -Wpointer-arith -Wbad-function-cast -Wnested-externs"
++ -Wpointer-arith -Wbad-function-cast -Wnested-externs -fgnu89-inline"
+ fi
+
+ CPPFLAGS="$CPPFLAGS -I$srcdir"