aboutsummaryrefslogtreecommitdiffstats
path: root/main/bash/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-11-06 18:03:27 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-11-06 18:03:27 +0000
commitcec73eedb763b803897e98f0a5b3934dc4be1fdd (patch)
tree3d488a2447fc1864e78183309bf55abef702b209 /main/bash/APKBUILD
parent46285f603510a45ffc93bc28d02f96ef2f68c298 (diff)
main/bash: fix applying vendor patches
Diffstat (limited to 'main/bash/APKBUILD')
-rw-r--r--main/bash/APKBUILD22
1 files changed, 19 insertions, 3 deletions
diff --git a/main/bash/APKBUILD b/main/bash/APKBUILD
index 910df6a5de1..16b3c716acb 100644
--- a/main/bash/APKBUILD
+++ b/main/bash/APKBUILD
@@ -6,7 +6,7 @@ pkgver=4.4.12
_patchlevel=${pkgver##*.}
_myver=${pkgver%.*}
_patchbase=${_myver/./}
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Bourne Again shell"
url="http://www.gnu.org/software/bash/bash.html"
arch="all"
@@ -30,13 +30,29 @@ while [ $_i -le $_patchlevel ]; do
done
# secfixes:
-# 4.4.12-r0:
-# - CCVE-2016-0634
+# 4.4.12-r1:
+# - CVE-2016-0634
builddir="$srcdir"/$pkgname-$_myver
prepare() {
cd "$builddir"
+
+ # NOTE: This section is for applying the vendor patches, which are required to fix
+ # security holes. `default_prepare` does *not* apply vendor patches in the format
+ # shipped with bash. We also need to make sure vendor patches are applied before
+ # our own.
+ # If you disagree, please request an experimental rebuild with bash as /bin/sh,
+ # before removing this section.
+ for p in $source; do
+ case $p in
+ */bash[0-9][0-9]-[0-9]*)
+ msg "$p (vendor)"
+ patch -p0 -i "$srcdir"/${p##*/} || return 1
+ ;;
+ esac
+ done
+
default_prepare
update_config_sub
}