aboutsummaryrefslogtreecommitdiffstats
path: root/main/bdftopcf/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2017-09-08 18:51:46 -0500
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-19 10:54:40 +0000
commit0c6d9f03dda8f5ecebe000b33dd0599c8c4e0ef8 (patch)
tree63951af5065d49d1a10675dae02f81e897d7ad6a /main/bdftopcf/APKBUILD
parent1e787a2c8b46158082cf41d4852dc146dcab76f0 (diff)
main/bdftopcf: modernise, fix deps, mark no tests
Diffstat (limited to 'main/bdftopcf/APKBUILD')
-rw-r--r--main/bdftopcf/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/main/bdftopcf/APKBUILD b/main/bdftopcf/APKBUILD
index 4ee5e7f682c..00291e90901 100644
--- a/main/bdftopcf/APKBUILD
+++ b/main/bdftopcf/APKBUILD
@@ -1,34 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bdftopcf
pkgver=1.0.5
-pkgrel=0
+pkgrel=1
pkgdesc="X.Org font utility"
url="http://xorg.freedesktop.org/"
arch="all"
license="MIT"
+options="!check" # No test suite.
depends=""
-makedepends="libxfont-dev"
+makedepends="libxfont-dev util-macros"
install=""
subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/app/bdftopcf-$pkgver.tar.bz2"
-_builddir="$srcdir"/$pkgname-$pkgver
-
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
- --with-mapdir=/usr/share/fonts/util \
- || return 1
- make || return 1
+ --with-mapdir=/usr/share/fonts/util
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
md5sums="53a48e1fdfec29ab2e89f86d4b7ca902 bdftopcf-1.0.5.tar.bz2"