summaryrefslogtreecommitdiffstats
path: root/main/bluez-hcidump
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-06 19:40:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-06 19:41:05 +0000
commitbeb1b1720862c18461a3488b1c15211df9c9ce14 (patch)
treeb6ad69fbf11d3812aa799de59659284fbed86ffd /main/bluez-hcidump
parent8d36e7d94c0c940d7eac811b442e210221e1275f (diff)
main/bluez-hcidump: moved from testing
Diffstat (limited to 'main/bluez-hcidump')
-rw-r--r--main/bluez-hcidump/APKBUILD39
-rw-r--r--main/bluez-hcidump/ntoh64.patch19
2 files changed, 58 insertions, 0 deletions
diff --git a/main/bluez-hcidump/APKBUILD b/main/bluez-hcidump/APKBUILD
new file mode 100644
index 00000000000..09b70920954
--- /dev/null
+++ b/main/bluez-hcidump/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bluez-hcidump
+pkgver=2.0
+pkgrel=1
+pkgdesc="Bluetooth HCI package analyzer"
+url="http://www.bluez.org/"
+arch="all"
+license="GPL2"
+depends=
+makedepends="bluez-dev"
+subpackages="$pkgname-doc"
+source="http://www.kernel.org/pub/linux/bluetooth/bluez-hcidump-$pkgver.tar.gz
+ ntoh64.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="5c2e3ef0a68b2845047867ba51ff8ac9 bluez-hcidump-2.0.tar.gz
+fee39a3c089125cdc9f7b01f84ea8b33 ntoh64.patch"
diff --git a/main/bluez-hcidump/ntoh64.patch b/main/bluez-hcidump/ntoh64.patch
new file mode 100644
index 00000000000..6ab411f54b3
--- /dev/null
+++ b/main/bluez-hcidump/ntoh64.patch
@@ -0,0 +1,19 @@
+--- ./src/hcidump.c.orig
++++ ./src/hcidump.c
+@@ -51,6 +51,8 @@
+ #include "parser/sdp.h"
+
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
++#if 0
++/* defined in bluetooth.h from bluez */
+ static inline uint64_t ntoh64(uint64_t n)
+ {
+ uint64_t h;
+@@ -59,6 +61,7 @@
+ h |= tmp << 32;
+ return h;
+ }
++#endif
+ #elif __BYTE_ORDER == __BIG_ENDIAN
+ #define ntoh64(x) (x)
+ #else