aboutsummaryrefslogtreecommitdiffstats
path: root/main/bluez
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-25 02:28:22 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-09-28 09:40:08 +0000
commit1d05c605dc9fef30850e45a2327040bfab0d11ca (patch)
tree60bc720922d8a88e3fd47e102397d8bb23058c73 /main/bluez
parent5967aba2ffb09dc1e45aca7b0233584eb4398a64 (diff)
main/bluez: upgrade to 5.51
Closes !125
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD46
-rw-r--r--main/bluez/bluez-5.40-obexd_without_systemd-1.patch61
-rw-r--r--main/bluez/musl.patch65
3 files changed, 98 insertions, 74 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 7b32a2c507c..ade2fd6e224 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
-pkgver=5.50
-pkgrel=4
+pkgver=5.51
+pkgrel=0
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -11,21 +11,32 @@ replaces="udev"
makedepends="dbus-dev libusb-compat-dev eudev-dev json-c-dev
libical-dev readline-dev glib-dev linux-headers
autoconf automake libtool ell-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bccmd $pkgname-btmgmt $pkgname-btmon $pkgname-cups
- $pkgname-deprecated $pkgname-hid2hci $pkgname-meshctl $pkgname-obexd"
+subpackages="
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-libs
+ $pkgname-bccmd
+ $pkgname-btmgmt
+ $pkgname-btmon
+ $pkgname-cups
+ $pkgname-deprecated
+ $pkgname-hid2hci
+ $pkgname-meshctl
+ $pkgname-obexd
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
source="https://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
bluetooth.initd
rfcomm.initd
rfcomm.confd
- 001-bcm43xx-Add-bcm43xx-3wire-variant.patch
- 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
- 003-Increase-firmware-load-timeout-to-30s.patch
- 004-Move-the-43xx-firmware-into-lib-firmware.patch
- bluez-5.40-obexd_without_systemd-1.patch
+ 001-bcm43xx-Add-bcm43xx-3wire-variant.patch
+ 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
+ 003-Increase-firmware-load-timeout-to-30s.patch
+ 004-Move-the-43xx-firmware-into-lib-firmware.patch
disable-lock-test.patch
fix-endianness.patch
+ musl.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -116,7 +127,16 @@ obexd() {
mv "$pkgdir"/usr/lib/bluetooth/obexd "$subpkgdir"/usr/lib/bluetooth
}
-sha512sums="64a680e4b3c270bc2439610c91ad2aef36131d84401e4bbdf6c2b7ec8708a19dfc942b31b9189c38a97ca072c761c669ae1aace5f4ff5d06de3ccbf33184be45 bluez-5.50.tar.xz
+zshcomp() {
+ depends=""
+ pkgdesc="Zsh compltions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ install -Dm644 "$pkgdir"/usr/share/zsh/site-functions/_bluetoothctl \
+ "$subpkgdir"/usr/share/zsh/site-functions/_bluetoothctl
+}
+
+sha512sums="8b14eea98f541b981162abce728e0f917654ad3c990721ec398fe41bdd68069fe55ff64b61bc3c3b9f813facf42c995b07619f6d5d153965de27154b1a7b578f bluez-5.51.tar.xz
fc43c78ed248ea412529eed5ae8bb47bacca9bf5b3b10de121ddd4e792c85893561a88be4aa2c6318106e5d2146a721445152d44fa60ca257ca0b4eb87318c1e bluetooth.initd
8d7b7c8938a2316ce0a855e9bdf1ef8fcdf33d23f4011df828270a088b88b140a19c432e83fef15355d0829e3c86be05b63e7718fef88563254ea239b8dc12ac rfcomm.initd
a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd
@@ -124,6 +144,6 @@ a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b34841
d5fd1c962bd846eaa6fff879bab85f753eb367d514f82d133b5d3242e1da989af5eddd942c60a87d5b67783e060f91bfa0f74fb1e8e6699cdee6e5bbe6a431ea 002-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
784e9644c8de4e2693e2eeed988a245608b8cb14e1fc0dff8795c60c527b2e8d0c87862cfbfd6b850b47ae80cdf993a5ed3f477078ea1068fd7374899c7a1a77 003-Increase-firmware-load-timeout-to-30s.patch
42ac04044a8c66e07487598b3a75ef52efc32999ebce4e7c63f6198e2f603f4a1442e74600e43a0938cb4f52d4db0298aa99050b18144b84990cda71748e9de5 004-Move-the-43xx-firmware-into-lib-firmware.patch
-41ce7ccf78cca97563f0ef31e01dac6eb4484c24fe57be360b5e8de8c5bff5845e9d395766f891bd3f123788344456c88c9fc00cd1bb7c6a1dca89d09f19172b bluez-5.40-obexd_without_systemd-1.patch
04c4889372c8e790bb338dde7ffa76dc32fcf7370025c71b9184fcf17fd01ade4a6613d84d648303af3bbc54043ad489f29fc0cd4679ec8c9029dcb846d7e026 disable-lock-test.patch
-118d55183860f395fc4bdc93efffb13902ebf7388cad722b9061cd2860d404333e500af521741c3d92c0f8a161f6810348fbeb6682e49c372383f417aed8c76a fix-endianness.patch"
+118d55183860f395fc4bdc93efffb13902ebf7388cad722b9061cd2860d404333e500af521741c3d92c0f8a161f6810348fbeb6682e49c372383f417aed8c76a fix-endianness.patch
+efc7dd70a44e3f5e7d3f9885ed4cbea78e616c56a1f88ffccdc142650b47378c86c8dd062545f95ae9f2f1916eec5ba4914fa49e07effb59d94b70e3809fd136 musl.patch"
diff --git a/main/bluez/bluez-5.40-obexd_without_systemd-1.patch b/main/bluez/bluez-5.40-obexd_without_systemd-1.patch
deleted file mode 100644
index 749787c5b3a..00000000000
--- a/main/bluez/bluez-5.40-obexd_without_systemd-1.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Submitted By: Armin K. <krejzi at email dot com>
-Date: 2013-04-29
-Initial Package Version: 5.17
-Upstream Status: unknown
-Origin: Arch Linux (Giovanni Campagna)
-Description: Allow using obexd without systemd in the user session
-
-Not all sessions run systemd --user (actually, the majority
-doesn't), so the dbus daemon must be able to spawn obexd
-directly, and to do so it needs the full path of the daemon.
----
- Makefile.obexd | 4 ++--
- obexd/src/org.bluez.obex.service | 4 ----
- obexd/src/org.bluez.obex.service.in | 4 ++++
- 3 files changed, 6 insertions(+), 6 deletions(-)
- delete mode 100644 obexd/src/org.bluez.obex.service
- create mode 100644 obexd/src/org.bluez.obex.service.in
-
-diff --git a/Makefile.obexd b/Makefile.obexd
-index 3760867..142e7c3 100644
---- a/Makefile.obexd
-+++ b/Makefile.obexd
-@@ -2,12 +2,12 @@
- if SYSTEMD
- systemduserunitdir = @SYSTEMD_USERUNITDIR@
- systemduserunit_DATA = obexd/src/obex.service
-+endif
-
- dbussessionbusdir = @DBUS_SESSIONBUSDIR@
- dbussessionbus_DATA = obexd/src/org.bluez.obex.service
--endif
-
--EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service
-+EXTRA_DIST += obexd/src/obex.service.in obexd/src/org.bluez.obex.service.in
-
- obex_plugindir = $(libdir)/obex/plugins
-
-diff --git a/obexd/src/org.bluez.obex.service b/obexd/src/org.bluez.obex.service
-deleted file mode 100644
-index a538088..0000000
---- a/obexd/src/org.bluez.obex.service
-+++ /dev/null
-@@ -1,4 +0,0 @@
--[D-BUS Service]
--Name=org.bluez.obex
--Exec=/bin/false
--SystemdService=dbus-org.bluez.obex.service
-diff --git a/obexd/src/org.bluez.obex.service.in b/obexd/src/org.bluez.obex.service.in
-new file mode 100644
-index 0000000..9c815f2
---- /dev/null
-+++ b/obexd/src/org.bluez.obex.service.in
-@@ -0,0 +1,4 @@
-+[D-BUS Service]
-+Name=org.bluez.obex
-+Exec=@libexecdir@/obexd
-+SystemdService=dbus-org.bluez.obex.service
---
-1.8.3.1
-
-
diff --git a/main/bluez/musl.patch b/main/bluez/musl.patch
new file mode 100644
index 00000000000..d732e6d8423
--- /dev/null
+++ b/main/bluez/musl.patch
@@ -0,0 +1,65 @@
+diff --git a/mesh/net.h b/mesh/net.h
+index 150240f..a3dec2b 100644
+--- a/mesh/net.h
++++ b/mesh/net.h
+@@ -21,6 +21,8 @@
+ #define __packed __attribute__((packed))
+ #endif
+
++#include <sys/time.h> /* for timeval */
++
+ struct mesh_io;
+ struct mesh_node;
+
+diff --git a/mesh/node.c b/mesh/node.c
+index b6824f5..ef7ede1 100644
+--- a/mesh/node.c
++++ b/mesh/node.c
+@@ -24,6 +24,7 @@
+ #define _GNU_SOURCE
+ #include <dirent.h>
+ #include <stdio.h>
++#include <limits.h> /* for PATH_MAX */
+ #include <sys/time.h>
+
+ #include <ell/ell.h>
+
+diff --git a/mesh/util.c b/mesh/util.c
+index 1455bde..c426fc3 100644
+--- a/mesh/util.c
++++ b/mesh/util.c
+@@ -25,6 +25,7 @@
+ #include <dirent.h>
+ #include <ftw.h>
+ #include <stdio.h>
++#include <limits.h> /* For PATH_MAX */
+ #include <time.h>
+ #include <sys/time.h>
+
+
+diff --git a/mesh/keyring.c b/mesh/keyring.c
+index 3a7f92f..accd2f1 100644
+--- a/mesh/keyring.c
++++ b/mesh/keyring.c
+@@ -25,6 +25,7 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <stdio.h>
++#include <limits.h> /* For PATH_MAX */
+ #include <unistd.h>
+ #include <dirent.h>
+
+
+diff --git a/mesh/mesh-config-json.c b/mesh/mesh-config-json.c
+index cafa2fd..b4d3efb 100644
+--- a/mesh/mesh-config-json.c
++++ b/mesh/mesh-config-json.c
+@@ -29,6 +29,7 @@
+ #include <libgen.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <limits.h> /* For PATH_MAX */
+ #include <unistd.h>
+
+ #include <sys/time.h>
+