summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-07-09 09:57:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-07-09 09:57:57 +0000
commit2728f1bf9db999a885ce77618b1d615646e4294f (patch)
tree70ce8800a9c4628f7d55b9e27d822beb6660ae3c /main/busybox
parentb52ed2e8577385022ce7a3d694410ef2159a3647 (diff)
main/busybox: fix for diff
fixes #381
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD4
-rw-r--r--main/busybox/diff.patch29
2 files changed, 32 insertions, 1 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index e77474a25a7..de31b98f60c 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.16.2
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license="GPL-2"
@@ -11,6 +11,7 @@ subpackages="$pkgname-static"
triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
+ diff.patch
flock-bb.patch
busyboxconfig"
@@ -69,5 +70,6 @@ static() {
md5sums="2ba980f720a5bdce4ec05423519acc35 busybox-1.16.2.tar.bz2
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
+f2d22840613fc6e3f359c87af9781caa diff.patch
20d9beea7d0c0aaca14553a8f98fee12 flock-bb.patch
4bc85af9dd659cbb83c9a819b3481a47 busyboxconfig"
diff --git a/main/busybox/diff.patch b/main/busybox/diff.patch
new file mode 100644
index 00000000000..947be700bdd
--- /dev/null
+++ b/main/busybox/diff.patch
@@ -0,0 +1,29 @@
+commit d1ed648727f3a0df2d067d869040306ba1e2c52e
+Author: Natanael Copa <natanael.copa@gmail.com>
+Date: Fri Jul 9 09:38:03 2010 +0000
+
+ diff: strip trailing / on dirs
+
+ fixes #2203
+ https://bugs.busybox.net/show_bug.cgi?id=2203
+
+diff --git a/editors/diff.c b/editors/diff.c
+index 07594e8..e2da626 100644
+--- a/editors/diff.c
++++ b/editors/diff.c
+@@ -788,9 +788,15 @@ static void diffdir(char *p[2], const char *s_start)
+
+ memset(&list, 0, sizeof(list));
+ for (i = 0; i < 2; i++) {
++ char *lc;
+ /*list[i].s = list[i].e = 0; - memset did it */
+ /*list[i].dl = NULL; */
+
++ /* trim trailing / in dirs. */
++ lc = last_char_is(p[i], '/');
++ if (lc && lc != p[i])
++ *lc = '\0';
++
+ /* We need to trim root directory prefix.
+ * Using list.len to specify its length,
+ * add_to_dirlist will remove it. */