summaryrefslogtreecommitdiffstats
path: root/main/cgit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-14 17:57:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-14 17:57:16 +0000
commit9ca82f726fc4b1f0a2391b06d5ac7656d66cefab (patch)
treec432eee1ad8b543b282beec214c471ceba3d7b10 /main/cgit
parent3ff3dbe55b44f36f3f30ada4fa3b2569c214b68a (diff)
main/[various]: rebuild against openssl-1.0
Diffstat (limited to 'main/cgit')
-rw-r--r--main/cgit/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/cgit/APKBUILD b/main/cgit/APKBUILD
index af8ea6d1979..6b30ed78460 100644
--- a/main/cgit/APKBUILD
+++ b/main/cgit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cgit
pkgver=0.8.3.1
-pkgrel=1
+pkgrel=2
_gitver=1.6.4.3
pkgdesc="a fast webinterface for git"
url="http://hjemli.net/git/cgit"
@@ -14,14 +14,17 @@ source="
"
_makeopts="NO_ICONV=YesPlease
- NO_NSEC=YesPlease
NO_TCLTK=YesPlease
NO_SVN_TESTS=YesPlease"
-build() {
+prepare() {
cd "$srcdir/$pkgname-$pkgver"
rm -rf git
ln -s ../git-$_gitver git
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
make $_makeopts
}