aboutsummaryrefslogtreecommitdiffstats
path: root/main/clang
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-26 14:50:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-26 14:53:02 +0000
commit32438e1cacd28ccce42a5187534b5cf5e3bfbf0f (patch)
tree128282c533c37ae37ddeda05135c9fbc17ac9749 /main/clang
parent62ce34954f9869f634ce7b5c0a1b2103c69294de (diff)
main/clang: increase default thread stack size to 2MiB
Apparently clang++ crashes when building chromium due to stack overflow. ref #11086 upstream report: https://github.com/llvm/llvm-project/issues/76
Diffstat (limited to 'main/clang')
-rw-r--r--main/clang/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/clang/APKBUILD b/main/clang/APKBUILD
index f936c4c6947..9e6e93ffccd 100644
--- a/main/clang/APKBUILD
+++ b/main/clang/APKBUILD
@@ -4,7 +4,7 @@
pkgname=clang
# Note: Update together with llvm.
pkgver=9.0.1
-pkgrel=1
+pkgrel=2
_llvmver=${pkgver%%.*}
pkgdesc="A C language family front-end for LLVM"
arch="all"
@@ -51,7 +51,7 @@ build() {
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_C_FLAGS_MINSIZEREL_INIT="$CFLAGS" \
-DCMAKE_CXX_FLAGS_MINSIZEREL_INIT="$CXXFLAGS" \
- -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS" \
+ -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS -Wl,-z,stack-size=2097152" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_VERBOSE_MAKEFILE=OFF \
-DCLANG_VENDOR=Alpine \