aboutsummaryrefslogtreecommitdiffstats
path: root/main/claws-mail/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-20 13:23:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-20 13:23:51 +0000
commit41a421fe3f64114a4d3cc6c93a65aa6ae2e26918 (patch)
tree9f71a8f3773848e9115e4289ab87fa75749b00a1 /main/claws-mail/APKBUILD
parent8fd9611f35a47c6c98c32d93e3dd1fcb8f64d61f (diff)
main/claws-mail: misc fixes
- fix building against gnutls-3 - split out pgp, smime and spamassassin plugins as subpackages - disable bogofilter since we have no bogofilter package - enable compface and trayicon
Diffstat (limited to 'main/claws-mail/APKBUILD')
-rw-r--r--main/claws-mail/APKBUILD43
1 files changed, 38 insertions, 5 deletions
diff --git a/main/claws-mail/APKBUILD b/main/claws-mail/APKBUILD
index 2dd456eb1d1..f1f921cc66f 100644
--- a/main/claws-mail/APKBUILD
+++ b/main/claws-mail/APKBUILD
@@ -1,12 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=claws-mail
pkgver=3.8.0
-pkgrel=2
+pkgrel=3
pkgdesc="A GTK+ based e-mail client."
url="http://www.claws-mail.org"
arch="all"
license="GPL3"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang
+ $pkgname-plugins-spamassassin:spamassassin
+ $pkgname-plugins-pgp:pgp
+ $pkgname-plugins-smime:smime
+ "
+
makedepends="gtk+-dev openssl-dev startup-notification-dev enchant-dev
libgcrypt-dev libsm-dev gnutls-dev curl-dev dbus-glib-dev
libetpan-dev openldap-dev gpgme-dev"
@@ -14,6 +19,7 @@ depends=
install=
source="http://downloads.sourceforge.net/sourceforge/sylpheed-claws/$pkgname-$pkgver.tar.bz2
libc-version.patch
+ claws_gnutls.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -37,7 +43,9 @@ build() {
--disable-crash-dialog \
--enable-pgpmime-plugin \
--enable-spamassassin-plugin \
- --enable-bogofilter-plugin \
+ --disable-bogofilter-plugin \
+ --enable-trayicon-plugin \
+ --enable-compface \
--disable-jpilot \
|| return 1
@@ -53,9 +61,34 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/claws-mail/plugins/*.la
- find tools -maxdepth 1 -type f -and -perm /111 -or -name '*.conf' | while read i; do
+ find tools -maxdepth 1 -type f -and -perm 111 -or -name '*.conf' | while read i; do
install -D -m755 ${i} "$pkgdir"/usr/lib/claws-mail/tools/${i}
done
}
+
+pgp() {
+ pkgdesc="PGP plugin for signing and encrypting with Claws Mail"
+ depends="pinentry-gtk"
+ mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
+ mv "$pkgdir"/usr/lib/claws-mail/plugins/pgp* \
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
+}
+
+spamassassin() {
+ pkgdesc="Spamassassin plugin for Claws Mail"
+ depends="spamassassin"
+ mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
+ mv "$pkgdir"/usr/lib/claws-mail/plugins/spamass* \
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
+}
+
+smime() {
+ pkgdesc="S/MIME support for Claws Mail"
+ mkdir -p "$subpkgdir"/usr/lib/claws-mail/plugins
+ mv "$pkgdir"/usr/lib/claws-mail/plugins/smime* \
+ "$subpkgdir"/usr/lib/claws-mail/plugins/
+}
+
md5sums="df9f1657d7f34959a2205344d952c2e3 claws-mail-3.8.0.tar.bz2
-f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch"
+f3416743b5d8ff97b5a3cc2f7efc2dc1 libc-version.patch
+7b5d7503a921d19350b0d7f1bc6a2910 claws_gnutls.patch"