aboutsummaryrefslogtreecommitdiffstats
path: root/main/coreutils/APKBUILD
diff options
context:
space:
mode:
authorPrzemyslaw Pawelczyk <przemoc@zoho.com>2016-12-11 22:46:32 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-12-12 13:43:45 -0300
commit1905f7d7adeb1b70d8d35f9602b439e0770472b2 (patch)
treebf65f616e715bb4ca2025bbf50b47c98c5044c1c /main/coreutils/APKBUILD
parent7b49c59191fc453f17f43927cc794a7ecf2dcbc0 (diff)
main/coreutils: Upgrade to 8.26. Modernize APKBUILD.
Many bugfixes and new tool: b2sum for BLAKE2 digest algorithm. http://git.savannah.gnu.org/cgit/coreutils.git/plain/NEWS?h=v8.26
Diffstat (limited to 'main/coreutils/APKBUILD')
-rw-r--r--main/coreutils/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/main/coreutils/APKBUILD b/main/coreutils/APKBUILD
index 6d1ac36f869..13273999f06 100644
--- a/main/coreutils/APKBUILD
+++ b/main/coreutils/APKBUILD
@@ -2,22 +2,21 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=coreutils
-pkgver=8.25
+pkgver=8.26
pkgrel=0
pkgdesc="The basic file, shell and text manipulation utilities"
url="http://www.gnu.org/software/coreutils/"
arch="all"
license="GPL3+"
-depends=
makedepends="bash acl-dev perl"
-install=
subpackages="$pkgname-doc"
install="$pkgname.post-deinstall"
source="http://ftp.gnu.org/gnu/coreutils/$pkgname-$pkgver.tar.xz"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
+
build() {
- cd "$_builddir"
+ cd "$builddir"
LIBS="-lrt" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,7 +32,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
rm -rf "$pkgdir"/usr/lib/charset.alias
@@ -51,6 +50,6 @@ package() {
mv chroot "$pkgdir"/usr/sbin/
}
-md5sums="070e43ba7f618d747414ef56ab248a48 coreutils-8.25.tar.xz"
-sha256sums="31e67c057a5b32a582f26408c789e11c2e8d676593324849dcf5779296cdce87 coreutils-8.25.tar.xz"
-sha512sums="571f95d44987d373081ed4c6ac82155ad3dcd95621d7b1a7163597e80ecbbafef2cd74b2ef594587a443a1a4355083879f898a286bb0230c48112d43d076ccd6 coreutils-8.25.tar.xz"
+md5sums="d5aa2072f662d4118b9f4c63b94601a6 coreutils-8.26.tar.xz"
+sha256sums="155e94d748f8e2bc327c66e0cbebdb8d6ab265d2f37c3c928f7bf6c3beba9a8e coreutils-8.26.tar.xz"
+sha512sums="1ca7b32a1564855e672f64cb815f858619dd4308af1c9763959d06fab1ecd51385c4c61d987ceec7ff6baaaac699f2db10be4be7e40b2c6a6d4ffc3911180b03 coreutils-8.26.tar.xz"