aboutsummaryrefslogtreecommitdiffstats
path: root/main/cups-filters/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-07-14 18:40:34 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-30 15:58:53 +0000
commit768d5fffa52a89142c0be4b0e2ba11f77d5331f9 (patch)
treea4eb07277615f5c56af4a2f19a479b5eaadbc7bf /main/cups-filters/APKBUILD
parent23318a71db3c41992acdbe68f110183b140e2be0 (diff)
main/cups-filters: clarify license, modernize, use https
Diffstat (limited to 'main/cups-filters/APKBUILD')
-rw-r--r--main/cups-filters/APKBUILD33
1 files changed, 11 insertions, 22 deletions
diff --git a/main/cups-filters/APKBUILD b/main/cups-filters/APKBUILD
index 18d95d61c9c..8e47e64c0dc 100644
--- a/main/cups-filters/APKBUILD
+++ b/main/cups-filters/APKBUILD
@@ -3,9 +3,9 @@ pkgname=cups-filters
pkgver=1.20.4
pkgrel=0
pkgdesc="OpenPrinting CUPS filters and backends"
-url="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdf_as_standard_print_job_format"
+url="https://wiki.linuxfoundation.org/openprinting/cups-filters"
arch="all"
-license="GPL-2.0 and GPL-2.0-or-later and GPL-3.0 and MIT"
+license="GPL-2.0-or-later LGPL-2.1-or-later MIT"
# while textonly is originally a bash script, it only needs a few changes
# to work with any shell (dash being the problematic one)
# foomatic-rip needs "a modern shell" in case the PPD requires some
@@ -21,22 +21,12 @@ makedepends="$depends_dev bash cups-dev libjpeg-turbo-dev poppler-dev zlib-dev
coreutils"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://www.openprinting.org/download/cups-filters/cups-filters-$pkgver.tar.xz
+source="https://www.openprinting.org/download/cups-filters/$pkgname-$pkgver.tar.xz
"
-
-_builddir="$srcdir"/cups-filters-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -49,24 +39,23 @@ build() {
--with-pdftops=pdftops \
--with-shell=/bin/sh \
--without-rcdir \
- --without-rclevels \
- || return 1
+ --without-rclevels
# workaround parallel build issue by building libcupsfilters.la first
- make libcupsfilters.la && make libfontembed.la && make || return 1
+ make libcupsfilters.la && make libfontembed.la && make
}
package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
#the pdf.utf-8 symlink isn't quite good enough
cd "$pkgdir"/usr/share/cups/charsets && \
- ln -s pdf.utf-8.simple pdf.UTF-8 || return 1
+ ln -s pdf.utf-8.simple pdf.UTF-8
}
dev() {
default_dev
# cupsfilters.drv needs pcl.h
- install -Dm644 "$_builddir"/filter/pcl.h \
+ install -Dm644 "$builddir"/filter/pcl.h \
"$pkgdir"/usr/share/cups/ppdc/pcl.h
}