aboutsummaryrefslogtreecommitdiffstats
path: root/main/datefudge/APKBUILD
diff options
context:
space:
mode:
authorSimon Frankenberger <simon@fraho.eu>2019-02-06 21:44:05 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-26 14:21:38 +0100
commitc7c7b0d49f863676ebca50afac0bb963aa24075c (patch)
treee9faf7b0ac2f6914ef19ac650ab6fd1138f7bc0e /main/datefudge/APKBUILD
parent4e6f1904e1577829bdd5d83a43b197ff7944e3bd (diff)
main/gnutls: Enable tests again
Diffstat (limited to 'main/datefudge/APKBUILD')
-rw-r--r--main/datefudge/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/datefudge/APKBUILD b/main/datefudge/APKBUILD
new file mode 100644
index 00000000000..6923285c339
--- /dev/null
+++ b/main/datefudge/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
+# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
+pkgname=datefudge
+pkgver=1.22
+pkgrel=0
+pkgdesc="Tool to fake the system date"
+url="https://packages.debian.org/sid/datefudge"
+arch="all"
+license="GPL-2.0"
+depends="coreutils"
+checkdepends="perl"
+subpackages="$pkgname-doc"
+source="http://deb.debian.org/debian/pool/main/d/datefudge/datefudge_${pkgver}.tar.xz
+musl.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ # fix Makefile, set the version number directly as dpkg-parsechangelog is not available
+ sed -i "s/^VERSION := .\+/VERSION := ${pkgver}/" Makefile
+ make all
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ make -j1 DESTDIR="$pkgdir" \
+ -C "$builddir" install
+}
+
+sha512sums="ed67d334ca8296ae1c7b5ee1efc6ec7aafaad0aeb9f0f0387245c2eeea94ccc59ab804778b93ab8b34a512b83a3ec81d10f341d4f4f22b4a07fccdadaefb6d8b datefudge_1.22.tar.xz
+e8b004957276f1162f9d686f03593cdd64455a35764e34aeac72d419b6ac071fb044405c73999283fcb9abff312225f81039553801cfaa1165bbbfc80705d44b musl.patch"