aboutsummaryrefslogtreecommitdiffstats
path: root/main/debootstrap
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-03-13 00:02:18 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-03-13 12:22:21 +0100
commit4d494a6b952c64270f5bb0e0aed2828df6ba5e5e (patch)
tree5774f74e7e7a1f7b7bfe4a45088696de5cbe36a9 /main/debootstrap
parentcc8e4ca0a1435c788714db98bbd6168ba990a98a (diff)
main/debootstrap: upgrade to 1.0.89
Diffstat (limited to 'main/debootstrap')
-rw-r--r--main/debootstrap/APKBUILD24
-rw-r--r--main/debootstrap/init-freedom-668001.patch40
-rwxr-xr-xmain/debootstrap/makedev.sh19
3 files changed, 3 insertions, 80 deletions
diff --git a/main/debootstrap/APKBUILD b/main/debootstrap/APKBUILD
index 1ac20a85117..0b08f5c56b0 100644
--- a/main/debootstrap/APKBUILD
+++ b/main/debootstrap/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=debootstrap
-pkgver=1.0.81
+pkgver=1.0.89
pkgrel=0
pkgdesc="Debian/Ubuntu bootstrap scripts"
url="http://packages.qa.debian.org/d/debootstrap.html"
@@ -10,32 +10,14 @@ license="GPL2"
depends="debian-archive-keyring dpkg tar"
makedepends=""
subpackages="$pkgname-doc"
-source="ftp://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}~bpo8+1.tar.gz
- init-freedom-668001.patch
- makedev.sh
- "
+source="ftp://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.gz"
builddir="$srcdir"/$pkgname
-prepare() {
- chmod +x "$srcdir/makedev.sh"
-}
-
package() {
cd "$builddir"
- make MAKEDEV="$srcdir/makedev.sh" \
- devices.tar.gz || return 1
-
make DESTDIR="$pkgdir" install || return 1
install -Dm644 $pkgname.8 \
"$pkgdir"/usr/share/man/man8/$pkgname.8 || return 1
}
-md5sums="034f76b175ecf2cec90b18e385d01b56 debootstrap_1.0.81~bpo8+1.tar.gz
-6338530a73af092b67da3979ff1cc642 init-freedom-668001.patch
-ef5038e52173de7a18c37a0925ccf383 makedev.sh"
-sha256sums="da0605f5f33ae7fcc644e0814ad5e84c5a6fecb506869297710d73a58fc03cdc debootstrap_1.0.81~bpo8+1.tar.gz
-3544d14c4269a52c98171088a067f2cff09765c154114196290640a060248c41 init-freedom-668001.patch
-3f26318b59c7697205285d04eb68a4c65905faedd7bbcb4e53e803f9ea8e5c97 makedev.sh"
-sha512sums="a56dc732f762841cf1c46c4df1274884cc40ead4b9d4ef7bf6e459521a0e22a5fe3a932111c274d337c7246b2ab87d2df2ab900b2ea6efd22c67241076652159 debootstrap_1.0.81~bpo8+1.tar.gz
-8690f5f190451ff981a0c53eb2369d4bdc24a724f16bcb8154b34d3a44de2183227bd2cb4418f1310220aa7b7294d82d4c04f2f238d26d99dcc5427850d74df8 init-freedom-668001.patch
-71f1dfe7d785cf5f4b2db7e4de01b5e542b33a1a49194a53665d4d68b5de47fc3c5b37ad2d1a7c37fb14d10c6758fa2fb043bd68a6fbb8b9dba90fb071a9db9c makedev.sh"
+sha512sums="3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a debootstrap_1.0.89.tar.gz"
diff --git a/main/debootstrap/init-freedom-668001.patch b/main/debootstrap/init-freedom-668001.patch
deleted file mode 100644
index c9c9eaef658..00000000000
--- a/main/debootstrap/init-freedom-668001.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Apply init freedom patch since Debian's maintainer is obstructing a bugfix to honor exclude directive and allow people to avoid having systemd at early stage, see bug 668001 in Debian
---- a/debootstrap
-+++ b/debootstrap
-@@ -51,7 +51,7 @@
- DEF_MIRROR="http://httpredir.debian.org/debian"
- DEF_HTTPS_MIRROR="https://mirrors.kernel.org/debian"
-
--export LANG USE_COMPONENTS
-+export LANG USE_COMPONENTS EXCLUDE
- umask 022
-
- ###########################################################################
---- a/functions
-+++ b/functions
-@@ -1181,6 +1181,8 @@
- perl -e '
- $prevpkg = "";
- @d = ();
-+my %exclude;
-+$exclude{$_} = 1 for split(" ", $ENV{"EXCLUDE"});
- while (<STDIN>) {
- chomp;
- if (/^Package: (.*)$/) {
-@@ -1197,9 +1199,13 @@
- $in = 0 if (/^$/);
- if ($in and (/^Depends: (.*)$/ or /^Pre-Depends: (.*)$/)) {
- for $d (split /\s*,\s*/, $1) {
-- $d =~ s/\s*[|].*$//;
-- $d =~ s/\s*[(].*[)]\s*//;
-- push @d, $d;
-+ for $p (split /\s*\|\s*/, $d) {
-+ $p =~ s/\s*[(].*[)]\s*//;
-+ if (!$exclude{$p}) {
-+ push @d, $p;
-+ last;
-+ }
-+ }
- }
- }
- }
diff --git a/main/debootstrap/makedev.sh b/main/debootstrap/makedev.sh
deleted file mode 100755
index bee4ff8fe74..00000000000
--- a/main/debootstrap/makedev.sh
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-# Use this instead of packaging makedev.
-
-# Exit on failure.
-set -e
-
-# Create devices in $PWD.
-ln -s /proc/self/fd fd
-ln -s fd/0 stdin
-ln -s fd/1 stdout
-ln -s fd/2 stderr
-mknod full c 1 7
-mknod null c 1 3
-mknod ptmx c 5 2
-mkdir pts shm
-mknod random c 1 8
-mknod tty c 5 0
-mknod urandom c 1 9
-mknod zero c 1 5