summaryrefslogtreecommitdiffstats
path: root/main/desktop-file-utils/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/desktop-file-utils/APKBUILD
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/desktop-file-utils/APKBUILD')
-rw-r--r--main/desktop-file-utils/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/main/desktop-file-utils/APKBUILD b/main/desktop-file-utils/APKBUILD
new file mode 100644
index 00000000000..b4b373fe130
--- /dev/null
+++ b/main/desktop-file-utils/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=desktop-file-utils
+pkgver=0.15
+pkgrel=1
+pkgdesc="Command line utilities for working with desktop entries"
+url="http://www.freedesktop.org/wiki/Software/desktop-file-utils"
+license="GPL"
+depends=
+makedepends="glib-dev libiconv-dev gettext-dev pkgconfig"
+triggers="$pkgname.trigger:/usr/share/applications"
+source="http://www.freedesktop.org/software/$pkgname/releases/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/desktop-file-utils-$pkgver
+
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="2fe8ebe222fc33cd4a959415495b7eed desktop-file-utils-0.15.tar.gz"