aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcpcd/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-09-10 17:02:41 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2015-09-15 10:20:26 +0200
commitbc0062a9199fc4e3fa2a47bbc32e23f05271c0e2 (patch)
tree828c09d8aadcf4116490d34705b48286a58ed247 /main/dhcpcd/APKBUILD
parentd1eec2ed77bf16f492905d514349025d3c20eb1a (diff)
main/dhcpcd: use /usr/lib as libexec directory
dhcpcd-dbus uses this directory too.
Diffstat (limited to 'main/dhcpcd/APKBUILD')
-rw-r--r--main/dhcpcd/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/main/dhcpcd/APKBUILD b/main/dhcpcd/APKBUILD
index 53ef2626fb8..5336d8864b7 100644
--- a/main/dhcpcd/APKBUILD
+++ b/main/dhcpcd/APKBUILD
@@ -1,15 +1,17 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dhcpcd
pkgver=6.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="RFC2131 compliant DHCP client"
url="http://roy.marples.name/projects/dhcpcd/"
arch="all"
license="BSD-2"
-depends=
-makedepends="linux-headers"
-install=
+depends=""
+depends_dev="linux-headers dbus-dev"
+makedepends="$depends_dev"
+install=""
subpackages="$pkgname-doc"
source="http://roy.marples.name/downloads/dhcpcd/$pkgname-$pkgver.tar.bz2
busybox-logger.patch
@@ -30,16 +32,17 @@ build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
- --libexecdir=/lib/dhcpcd \
- --dbdir=/var/lib/dhcpcd \
+ --libexecdir=/usr/lib/$pkgname \
+ --dbdir=/var/lib/$pkgname \
|| return 1
- make
+ make || return 1
}
package() {
cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/dhcpcd.initd "$pkgdir"/etc/init.d/dhcpcd
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm755 "$srcdir"/dhcpcd.initd \
+ "$pkgdir"/etc/init.d/dhcpcd || return 1
}
md5sums="374fcac1877078a2fc0ef8cd1617a869 dhcpcd-6.9.0.tar.bz2