aboutsummaryrefslogtreecommitdiffstats
path: root/main/diffutils/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-03-15 07:26:08 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-03-15 07:26:08 +0000
commit00f110542c44a4cd05f8e93bdc8844205a4cc71c (patch)
tree9d61b604815dc84df093c4a223663629f1ebe6ad /main/diffutils/APKBUILD
parentc1507f17c5a05c870517164d113ede904d2f5a8e (diff)
main/diffutils: upgrade to 2.9
Diffstat (limited to 'main/diffutils/APKBUILD')
-rw-r--r--main/diffutils/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/main/diffutils/APKBUILD b/main/diffutils/APKBUILD
index 5a9177130f2..004d0e91fb8 100644
--- a/main/diffutils/APKBUILD
+++ b/main/diffutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
pkgname=diffutils
-pkgver=2.8.1
-pkgrel=1
+pkgver=2.9
+pkgrel=0
pkgdesc="Show differences among files"
subpackages="$pkgname-doc"
url="http://www.gnu.org/software/diffutils/"
@@ -9,18 +9,24 @@ license="GPL2"
depends="uclibc"
makedepends=""
install="$pkgname.post-deinstall"
-source="http://ftp.gnu.org/pub/gnu/diffutils/diffutils-2.8.1.tar.gz
+source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
$install"
+_builddir=$srcdir/$pkgname-$pkgver
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info
make || return 1
- make check || return 1
+}
+
+package() {
+ cd "$_builddir"
make install DESTDIR=$pkgdir
}
-md5sums="71f9c5ae19b60608f6c7f162da86a428 diffutils-2.8.1.tar.gz
+
+md5sums="d6bc1bdc874ddb14cfed4d1655a0dbbe diffutils-2.9.tar.gz
e8da9a22c2389fe5e2846b8c0de45767 diffutils.post-deinstall"