aboutsummaryrefslogtreecommitdiffstats
path: root/main/djbdns/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-18 16:16:36 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-18 16:17:03 +0100
commit9522f53d78e887a4081f028662e6ae9bda6a04c7 (patch)
tree4331b763a118f8e8a006b0305501c21bf0a0de68 /main/djbdns/APKBUILD
parent95429f61de2bf92f4efba55bdcdb4862818dd260 (diff)
main/djbdns: fix tinydns on 64 bit - including uint32.h
The jumbo patch includes the 32bit version of the generated header files. This might break 64 bit builds depending on unpacking timestamps etc. We fix it by removing the generated headers, including uint32.h ref #933
Diffstat (limited to 'main/djbdns/APKBUILD')
-rw-r--r--main/djbdns/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/djbdns/APKBUILD b/main/djbdns/APKBUILD
index 148ab2ec3d5..f47a180bf46 100644
--- a/main/djbdns/APKBUILD
+++ b/main/djbdns/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=djbdns
pkgver=1.05
-pkgrel=40
+pkgrel=42
pkgdesc="Excellent high-performance DNS services"
url="http://cr.yp.to/djbdns.html"
arch="all"
@@ -34,6 +34,9 @@ prepare() {
*.diff.gz) msg $i; gunzip -c "$srcdir"/$i | patch -p1 || return 1;;
esac
done
+ # remove all the generated headers. they came with the jumbo patch and should
+ # never have been there...
+ sed -n 's/^\([a-z0-9]\+\.h\):.*/\1/gp' Makefile Makefile.sig | xargs rm -f
}
build() {