aboutsummaryrefslogtreecommitdiffstats
path: root/main/doxygen
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-01-05 16:56:44 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-01-05 17:47:58 +0100
commit087f514a2406a33ebce1725a2d5b8d3c9b233c0c (patch)
tree64ad91d1637df7726fbd7ade98eb6e708885e3a8 /main/doxygen
parentb9e9dda696cbdd8e0b538ceb3fc374f084829422 (diff)
main/doxygen: upgrade to 1.8.17
Diffstat (limited to 'main/doxygen')
-rw-r--r--main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch80
-rw-r--r--main/doxygen/APKBUILD10
-rw-r--r--main/doxygen/doxygen-1.8.14-install.patch17
3 files changed, 99 insertions, 8 deletions
diff --git a/main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch b/main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch
new file mode 100644
index 00000000000..9a895255bce
--- /dev/null
+++ b/main/doxygen/0001-issue-7464-1.8.17-test-suite-is-failing.patch
@@ -0,0 +1,80 @@
+From cd9dee013dc749a10bbe019c350e0e62b6635795 Mon Sep 17 00:00:00 2001
+From: albert-github <albert.tests@gmail.com>
+Date: Wed, 1 Jan 2020 17:51:53 +0100
+Subject: [PATCH] issue #7464 1.8.17: test suite is failing
+
+On Windows the syntax with the command and arguments in one string worked but on *nix (and Cygwin) it didn't.
+- changed calls to Popen to split command (see also: https://docs.python.org/3/library/subprocess.html).
+- explicitly specify files to check for xhtml
+- changed call to xmllint for xhtml and docbook (due to stdout overflow in some cases, we are not really interested in the, formatted, output of xmllint).
+- in the update part a `read` was left, should have been removed.
+---
+ testing/runtests.py | 19 ++++++++++++-------
+ 1 file changed, 12 insertions(+), 7 deletions(-)
+
+diff --git a/testing/runtests.py b/testing/runtests.py
+index a4118b86..10fe5021 100755
+--- a/testing/runtests.py
++++ b/testing/runtests.py
+@@ -3,6 +3,7 @@
+ from __future__ import print_function
+ import argparse, glob, itertools, re, shutil, os, sys
+ import subprocess
++import shlex
+
+ config_reg = re.compile('.*\/\/\s*(?P<name>\S+):\s*(?P<value>.*)$')
+
+@@ -28,10 +29,10 @@ def xpopen(cmd, cmd1="",encoding='utf-8-sig', getStderr=False):
+ return os.popen(cmd).read() # Python 2 without encoding
+ else:
+ if (getStderr):
+- proc = subprocess.run(cmd1,encoding=encoding,capture_output=True) # Python 3 with encoding
+- return proc.stderr
++ proc = subprocess.Popen(shlex.split(cmd1),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
++ return proc.stderr.read()
+ else:
+- proc = subprocess.Popen(cmd,stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
++ proc = subprocess.Popen(shlex.split(cmd),stdout=subprocess.PIPE,stderr=subprocess.PIPE,encoding=encoding) # Python 3 with encoding
+ return proc.stdout.read()
+
+ class Tester:
+@@ -137,7 +138,7 @@ class Tester:
+ print('GENERATE_DOCBOOK=NO', file=f)
+ if (self.args.xhtml):
+ print('GENERATE_HTML=YES', file=f)
+- # HTML_OUTPUT can also be set locally
++ # HTML_OUTPUT can also have been set locally
+ print('HTML_OUTPUT=%s/html' % self.test_out, file=f)
+ print('HTML_FILE_EXTENSION=.xhtml', file=f)
+ if (self.args.pdf):
+@@ -184,7 +185,7 @@ class Tester:
+ print('Non-existing file %s after \'check:\' statement' % check_file)
+ return
+ # convert output to canonical form
+- data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file)).read()
++ data = xpopen('%s --format --noblanks --nowarning %s' % (self.args.xmllint,check_file))
+ if data:
+ # strip version
+ data = re.sub(r'xsd" version="[0-9.-]+"','xsd" version=""',data).rstrip('\n')
+@@ -326,7 +327,7 @@ class Tester:
+ tests.append(glob.glob('%s/*.xml' % (docbook_output)))
+ tests.append(glob.glob('%s/*/*/*.xml' % (docbook_output)))
+ tests = ' '.join(list(itertools.chain.from_iterable(tests))).replace(self.args.outputdir +'/','').replace('\\','/')
+- exe_string = '%s --nonet --postvalid %s' % (self.args.xmllint,tests)
++ exe_string = '%s --noout --nonet --postvalid %s' % (self.args.xmllint,tests)
+ exe_string1 = exe_string
+ exe_string += ' %s' % (redirx)
+ exe_string += ' %s more "%s/temp"' % (separ,docbook_output)
+@@ -346,7 +347,11 @@ class Tester:
+ redirx=' 2> %s/temp >nul:'%html_output
+ else:
+ redirx='2>%s/temp >/dev/null'%html_output
+- exe_string = '%s --path dtd --nonet --postvalid %s/*xhtml' % (self.args.xmllint,html_output)
++ check_file = []
++ check_file.append(glob.glob('%s/*.xhtml' % (html_output)))
++ check_file.append(glob.glob('%s/*/*/*.xhtml' % (html_output)))
++ check_file = ' '.join(list(itertools.chain.from_iterable(check_file))).replace(self.args.outputdir +'/','').replace('\\','/')
++ exe_string = '%s --noout --path dtd --nonet --postvalid %s' % (self.args.xmllint,check_file)
+ exe_string1 = exe_string
+ exe_string += ' %s' % (redirx)
+ exe_string += ' %s more "%s/temp"' % (separ,html_output)
diff --git a/main/doxygen/APKBUILD b/main/doxygen/APKBUILD
index 3aef1dc9112..83645649e38 100644
--- a/main/doxygen/APKBUILD
+++ b/main/doxygen/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=doxygen
-pkgver=1.8.16
-pkgrel=1
+pkgver=1.8.17
+pkgrel=0
pkgdesc="A documentation system for C++, C, Java, IDL and PHP"
url="http://www.doxygen.nl/"
arch="all"
@@ -10,6 +10,7 @@ checkdepends="libxml2-utils"
makedepends="flex bison coreutils perl python3 cmake"
source="http://doxygen.nl/files/doxygen-$pkgver.src.tar.gz
doxygen-1.8.14-install.patch
+ 0001-issue-7464-1.8.17-test-suite-is-failing.patch
"
build() {
@@ -34,5 +35,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="46a0189aa82d5a687bdd99a904f0c061fccca407d15867d14c8c4d13e8b21a8989e7ccd6af30840803b589ed20dd86084a4db880fba0d3bfa1fdcdd8d23e12de doxygen-1.8.16.src.tar.gz
-725a29a6f21ffc8ec6ca8ed6d746a69cc78060e97704c7fe909abee603ba0a99f27dc3b80c414afd886d0ee81d9948b13f29c43f7db2e00aae8c0c3a32aa9ec1 doxygen-1.8.14-install.patch"
+sha512sums="2fd087d127e301ea48355ea52c9af4f2091df06551cf64da80df81f0758194b296efb1e8d3962867a6a6d2da5a3fc323842f7766a445748005b30097ded30a75 doxygen-1.8.17.src.tar.gz
+a11ece43c640ffed707240f726b2005e103294e0351d7c3b6dd46ecc9bc0341b56c4bfb4e4daead3683129a1f332f283c578258aa1f611ec5a57c4da3bff8a21 doxygen-1.8.14-install.patch
+5b2dc0bc3dfa9b11c0ecf28e1d502f2c1112e67b47d191aa2cf294f74e41580881e02cf009c7de06dc75b0b0c0306d5c03eeca37b0f82c65e5a51cd68738e4c3 0001-issue-7464-1.8.17-test-suite-is-failing.patch"
diff --git a/main/doxygen/doxygen-1.8.14-install.patch b/main/doxygen/doxygen-1.8.14-install.patch
index 71448b8b4b0..748b0be77fe 100644
--- a/main/doxygen/doxygen-1.8.14-install.patch
+++ b/main/doxygen/doxygen-1.8.14-install.patch
@@ -1,11 +1,12 @@
---- doxygen-1.8.14/doc/CMakeLists.txt.config 2017-12-31 15:28:32.351163123 +0100
-+++ doxygen-1.8.14/doc/CMakeLists.txt 2017-12-31 15:29:11.490119182 +0100
-@@ -168,15 +168,15 @@ install(FILES
+diff -upr doxygen-1.8.17.orig/doc/CMakeLists.txt doxygen-1.8.17/doc/CMakeLists.txt
+--- doxygen-1.8.17.orig/doc/CMakeLists.txt 2020-01-05 16:37:34.415645891 +0100
++++ doxygen-1.8.17/doc/CMakeLists.txt 2020-01-05 16:38:10.395666071 +0100
+@@ -209,22 +209,22 @@ install(FILES
"${PROJECT_BINARY_DIR}/man/doxywizard.1"
"${PROJECT_BINARY_DIR}/man/doxysearch.1"
"${PROJECT_BINARY_DIR}/man/doxyindexer.1"
- DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
-+ DESTINATION "${MAN_INSTALL_DIR}"
++ DESTINATION ${CMAKE_INSTALL_MANDIR}
)
install(FILES
@@ -14,6 +15,14 @@
+ DESTINATION "${DOC_INSTALL_DIR}"
)
+ if (build_doc_chm)
+ install(FILES
+ "${PROJECT_BINARY_DIR}/chm/doxygen_manual.chm"
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/${DOC_INSTALL_DIR}"
++ DESTINATION "${DOC_INSTALL_DIR}"
+ )
+ endif ()
+
install(DIRECTORY
"${PROJECT_BINARY_DIR}/html"
- DESTINATION "${CMAKE_INSTALL_PREFIX}/${DOC_INSTALL_DIR}"