aboutsummaryrefslogtreecommitdiffstats
path: root/main/duplicity/APKBUILD
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2018-07-08 17:18:58 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-13 16:39:48 +0000
commit744aba7e8f1e3b4a003a01bcea425f1d6fe1f0cb (patch)
treef71ae9c458fa72af5659051a50219515813dbdb0 /main/duplicity/APKBUILD
parenta9910106c42a286107a71f3f4cd75b6948177642 (diff)
main/duplicity: fix dependencies and add check
Diffstat (limited to 'main/duplicity/APKBUILD')
-rw-r--r--main/duplicity/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/duplicity/APKBUILD b/main/duplicity/APKBUILD
index 8f2895c6e71..c8bfa799498 100644
--- a/main/duplicity/APKBUILD
+++ b/main/duplicity/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
url="http://duplicity.nongnu.org/"
arch="all"
license="GPL"
-depends="python2 py-boto gnupg ncftp py-lockfile"
+depends="python2 py-boto gnupg ncftp py2-fasteners"
makedepends="python2-dev py-setuptools librsync-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://code.launchpad.net/$pkgname/${pkgver:0:3}-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"
@@ -19,6 +19,14 @@ build() {
python2 setup.py build
}
+check() {
+ cd "$builddir/duplicity"
+ python2 compilec.py
+ cd ..
+ # Run a simple smoke-test
+ PYTHONPATH="$PWD" python2 bin/duplicity -V | grep -q duplicity
+}
+
package() {
cd "$builddir"
python2 setup.py install --root "$pkgdir"