aboutsummaryrefslogtreecommitdiffstats
path: root/main/duplicity/APKBUILD
diff options
context:
space:
mode:
authorStefan Reiff <kroko87@hotmail.com>2019-09-27 15:34:43 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-10-01 09:02:34 +0000
commitd53444d03dd75499e675a584379637c93d0664bc (patch)
tree9b7be1338a61c7a4b5e31c1ffc3b2483b40889f6 /main/duplicity/APKBUILD
parenta6d05f7993bf4be91fe324afe3df214a38fdfa6c (diff)
main/duplicity: upgrade to 0.8.04 and move to python3
Diffstat (limited to 'main/duplicity/APKBUILD')
-rw-r--r--main/duplicity/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/main/duplicity/APKBUILD b/main/duplicity/APKBUILD
index fb405ba5073..e91aad37d4b 100644
--- a/main/duplicity/APKBUILD
+++ b/main/duplicity/APKBUILD
@@ -2,34 +2,30 @@
# Contributor: Matt Smith <mcs@darkregion.net>
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=duplicity
-pkgver=0.7.19
+pkgver=0.8.04
pkgrel=0
pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
url="http://duplicity.nongnu.org/"
arch="all"
license="GPL-2.0-or-later"
-depends="python2 py-boto gnupg ncftp py2-fasteners"
-makedepends="python2-dev py-setuptools librsync-dev"
+depends="python3 py3-boto gnupg ncftp py3-fasteners"
+makedepends="python3-dev py3-future py3-setuptools librsync-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://code.launchpad.net/$pkgname/${pkgver:0:3}-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+#builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
check() {
- cd "$builddir/duplicity"
- python2 compilec.py
- cd ..
+ python3 compilec.py
# Run a simple smoke-test
- PYTHONPATH="$PWD" python2 bin/duplicity -V | grep -q duplicity
+ PYTHONPATH="$PWD" python3 bin/duplicity -V | grep -q duplicity
}
package() {
- cd "$builddir"
- python2 setup.py install --root "$pkgdir"
+ python3 setup.py install --root "$pkgdir"
}
-sha512sums="26d1724a635c368e04f2a94f974ef6962c52b23345db59af3343e7221295caa0215ae119fff6ab44daa4622236683eb9d3dae742bf0d4cf08c02e3f63071001b duplicity-0.7.19.tar.gz"
+sha512sums="ca39e282df9de518535f56fc2b8912426faac069df66d394f191de4ef7edf5c8ebe03623b78c793a7f2615ddb4b3af7f3010150d1fcd6918428db45c5b62b9cf duplicity-0.8.04.tar.gz"