aboutsummaryrefslogtreecommitdiffstats
path: root/main/fakeroot
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-03-07 11:23:39 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-03-07 11:23:39 +0200
commite56db141ce09c403f59621b4e56a8025a387ef6c (patch)
tree6307e4140771da3700e649bae89e24c2c62475f1 /main/fakeroot
parent4b3e3f7ab3af18ea69b20f4f3b99e09d32b2989d (diff)
main/fakeroot: hide unharmful dlsym errors
this got uncovered when we enabled libacl support. the acl_* symbols are tried to be resolved but they will not exist in the app, if it's not linked against -lacl. it's perfectly ok for these to not be found.
Diffstat (limited to 'main/fakeroot')
-rw-r--r--main/fakeroot/APKBUILD6
-rw-r--r--main/fakeroot/fakeroot-hide-dlsym-errors.patch20
2 files changed, 25 insertions, 1 deletions
diff --git a/main/fakeroot/APKBUILD b/main/fakeroot/APKBUILD
index 578f056bf81..a04750f84f7 100644
--- a/main/fakeroot/APKBUILD
+++ b/main/fakeroot/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fakeroot
pkgver=1.20
-pkgrel=1
+pkgrel=2
pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
arch="all"
license='GPL'
@@ -12,6 +12,7 @@ makedepends="$makedepends_host"
subpackages="$pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
busybox-getopt.patch
+ fakeroot-hide-dlsym-errors.patch
fakeroot-no64.patch
fakeroot-stdint.patch
fakeroot-uclibc.patch"
@@ -58,16 +59,19 @@ package() {
md5sums="9777a81d4d1878422447a1d0030c1f9f fakeroot_1.20.orig.tar.bz2
bdbf1db14f2cfdff0f5b4c35da78b9fe busybox-getopt.patch
+624cd86a66d020d01bde4ba60efc4d40 fakeroot-hide-dlsym-errors.patch
3fc66a8ffb365fcf2acd652d33f101a2 fakeroot-no64.patch
50a899380cfd5eae8ce3aaf878fb17b2 fakeroot-stdint.patch
7a54ab51fdb90bc44e366e0a66811bfe fakeroot-uclibc.patch"
sha256sums="2297b7e79487cf0bbc64ff6d3d02446d895e82e2b26467c74fd1119011f6f098 fakeroot_1.20.orig.tar.bz2
e915ce6cf414da590d39c735e1e522725717f43bfe6da77bd62cd1be365a06ec busybox-getopt.patch
+915313c164b2968bc785621d14e652aae0bb74cec01510457d1fa601f23e0ca2 fakeroot-hide-dlsym-errors.patch
3420da0789caef582fcfc890c657da4136b3b06d1205443f4409cdf85ab02a46 fakeroot-no64.patch
8739c0b79c3f2b0e46cd0dffa8b73d946efbe994f61f69f7d1115c2dcec22df1 fakeroot-stdint.patch
e325ad9aad310caa71002adea220795f706c621c5794093f16c0f319b3d58977 fakeroot-uclibc.patch"
sha512sums="b041ab87559f784041f05bfa9d5186ceaafebbcbd03057ede62bf420551e337ceec4b7101854937e206c6389ac2c0719545d5971457edaf564856bb44ce7b4b6 fakeroot_1.20.orig.tar.bz2
3a3cfcddbfe6685111d2a9dd93ebe5816bacab664aa19004cc39e18c00b5ef8045cb153755f66cabb204f17e2495ce38e2fb37fdc8da01cc69ec62e4694e3001 busybox-getopt.patch
+666f41d6adc5e65eba419e08d5bbc4f561e40b0fc7bfa82090eb87962a7f3193bf319754e04aca289e865c66df2ecced1dbb45c9aa9f093657f22193dda25354 fakeroot-hide-dlsym-errors.patch
7a832e6bed3838c7c488e0e12ba84b8d256e84bbb06d6020247452a991de505fa5c6bd7bcb84dce8753eb242e0fcab863b5461301cd56695f2b003fe8d6ff209 fakeroot-no64.patch
ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
783ceaf00c6c1c190327dbc3f67761488aaeb23e40b3a249bcaf301f99334721a864f8a730abfb0e17467bad24f5db9127d83379dea3ef24b6f708ff7dfb3f98 fakeroot-uclibc.patch"
diff --git a/main/fakeroot/fakeroot-hide-dlsym-errors.patch b/main/fakeroot/fakeroot-hide-dlsym-errors.patch
new file mode 100644
index 00000000000..aeeb347da67
--- /dev/null
+++ b/main/fakeroot/fakeroot-hide-dlsym-errors.patch
@@ -0,0 +1,20 @@
+it's normal that the acl_* symbols are not found if the application
+is not linked against -lacl. these errors harmless, but mighty
+annoying.
+
+--- fakeroot-1.20/libfakeroot.c.orig 2014-03-07 11:20:26.120532847 +0200
++++ fakeroot-1.20/libfakeroot.c 2014-03-07 11:21:26.486872482 +0200
+@@ -258,10 +258,12 @@
+ /* clear dlerror() just in case dlsym() legitimately returns NULL */
+ msg = dlerror();
+ *(next_wrap[i].doit)=dlsym(get_libc(), next_wrap[i].name);
+- if ( (msg = dlerror()) != NULL){
++#ifdef LIBFAKEROOT_DEBUGGING
++ if ( fakeroot_debug && (msg = dlerror()) != NULL) {
+ fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
+ /* abort ();*/
+ }
++#endif
+ }
+ }
+