aboutsummaryrefslogtreecommitdiffstats
path: root/main/fetchmail/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/fetchmail/APKBUILD
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/fetchmail/APKBUILD')
-rw-r--r--main/fetchmail/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/fetchmail/APKBUILD b/main/fetchmail/APKBUILD
index 57dbfaf21ed..43f4663e581 100644
--- a/main/fetchmail/APKBUILD
+++ b/main/fetchmail/APKBUILD
@@ -15,8 +15,15 @@ install="fetchmail.pre-install"
subpackages="$pkgname-doc fetchmailconf"
source="http://download.berlios.de/fetchmail/$pkgname-$pkgver.tar.bz2
fetchmail.initd"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure \
--build=$CBUILD \
@@ -32,7 +39,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/fetchmail.initd "$pkgdir"/etc/init.d/fetchmail
install -o fetchmail -g fetchmail -d "$pkgdir"/var/lib/fetchmail \