aboutsummaryrefslogtreecommitdiffstats
path: root/main/ffmpeg/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-28 09:44:39 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-28 09:44:39 +0000
commitea3ce4390ea88dd4dac6ccf0b8c7cbfe066abba8 (patch)
tree90a92c1d6a18335c9e638a1d8b869c9ebaa85fc7 /main/ffmpeg/APKBUILD
parent811b614c13a82bd3fbceec051525833c9df0f5ab (diff)
main/ffmpeg: fix arm build
arm assembly has textrel's disable assembly for now.
Diffstat (limited to 'main/ffmpeg/APKBUILD')
-rw-r--r--main/ffmpeg/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/ffmpeg/APKBUILD b/main/ffmpeg/APKBUILD
index 944d1a54079..8fbab1057eb 100644
--- a/main/ffmpeg/APKBUILD
+++ b/main/ffmpeg/APKBUILD
@@ -31,7 +31,11 @@ build() {
local _dbg="--disable-debug"
local _asm=""
[ -n "$DEBUG" ] && _dbg="--enable-debug"
- [ "$CARCH" = "x86" ] && _asm="--disable-asm"
+
+ case "$CARCH" in
+ x86 | arm*) _asm="--disable-asm" ;;
+ esac
+
cd "$_builddir"
./configure \
--prefix=/usr \