aboutsummaryrefslogtreecommitdiffstats
path: root/main/font-bitstream-type1
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/font-bitstream-type1
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/font-bitstream-type1')
-rw-r--r--main/font-bitstream-type1/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/font-bitstream-type1/APKBUILD b/main/font-bitstream-type1/APKBUILD
new file mode 100644
index 00000000000..12f38f0413f
--- /dev/null
+++ b/main/font-bitstream-type1/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=font-bitstream-type1
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="X.org bitstream Type1 fonts"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends="encodings font-alias mkfontscale mkfontdir fontconfig"
+makedepends="pkgconfig font-util-dev bdftopcf"
+install=
+source="http://xorg.freedesktop.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-mapfiles=/usr/share/fonts/util \
+ --with-fontdir=/usr/share/fonts/Type1
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" MKFONTDIR=: MKFONTSCALE=: install || return 1
+}
+
+md5sums="6610475e2e231242f8f2122a709c3695 font-bitstream-type1-1.0.0.tar.bz2"