aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-30 13:42:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-30 13:44:37 +0000
commit54d0004b9355ac4d464880bf81a552334bb38026 (patch)
tree1dd27c3c6554f09557cdb6561016fe2b2f7bf20b /main/freeswitch/APKBUILD
parent4ce598e0e91cf9ecb264d0ea5522f4078f23caaf (diff)
main/freeswitch: move scripts dir to /etc/freeswitch/
sneak in a gcc-4.5 build fix too... fixes #430
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 1a274535737..ede3233e4dd 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=13
+pkgrel=14
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
depends=""
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
autoconf automake libtool"
-install="$pkgname.pre-install $pkgname.post-install"
+install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
modules.conf
@@ -27,6 +27,9 @@ build() {
# by specifying it here we save our selves from some CPU cycles
export lt_cv_sys_max_cmd_len=8192
+ # remove -Werror since gcc-4.5 is more strict
+ sed -i -e 's/-Werror//g' configure || return 1
+
./configure --prefix=/usr \
--sysconfdir=/etc/freeswitch \
--with-modinstdir=/usr/lib/freeswitch \
@@ -34,13 +37,15 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-devrandom=/dev/urandom \
+ --disable-debug \
|| return 1
# flite does not work with parallel builds
# first build libfreeswitch (in parallel)
+ make src/include/switch_version.h src/include/switch_swigable_cpp.h
make libfreeswitch.la || return 1
- # then we build mod_flite, disabling parallel builds
- ( cd src/mod/asr_tts/mod_flite && make -j1 ) || return 1
+ # then we build modules, disabling parallel builds
+ ( cd src/mod && make -j1 ) || return 1
# finally we build the rest
make all || return 1
}
@@ -56,7 +61,7 @@ package(){
mv "$pkgdir"/usr/grammar "$pkgdir"/var/lib/freeswitch/
mv "$pkgdir"/usr/htdocs "$pkgdir"/usr/share/freeswitch/
mv "$pkgdir"/usr/recordings "$pkgdir"/var/lib/freeswitch/
- mv "$pkgdir"/usr/scripts "$pkgdir"/usr/share/freeswitch/
+ mv "$pkgdir"/usr/scripts "$pkgdir"/etc/freeswitch/
mv "$pkgdir"/usr/log "$pkgdir"/var/log/freeswitch
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
@@ -90,9 +95,10 @@ conf() {
[ "$i" = "$pkgdir"/etc/freeswitch/freeswitch.xml ] && continue
mv "$i" "$subpkgdir"/etc/freeswitch/ || return 1
done
+ mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
1f9ed1daf9a1fb910571857c27b933ad modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-6973e15d72e5876152b160bd9e8d282b freeswitch.initd"
+aa358c9ca0d8b93fabb6a36a5ed4c469 freeswitch.initd"