aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorJeff Bilyk <jbilyk@gmail.com>2011-01-21 23:34:32 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-21 17:58:40 -0600
commitad7f39fa0464538e97c3b1e5acf3e61c8fb9f623 (patch)
tree505fe2ee0362067b6ed40b4a66a114b784bd70d1 /main/freeswitch/APKBUILD
parentb149c64a8e7c99e726df1d2d0b956b2662a20d03 (diff)
main/freeswitch: add support for freetdm and libpri
ref # 514
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 9730a895f93..868ff7c9da2 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -2,14 +2,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=14
+pkgrel=15
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
license="GPL"
depends=""
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
- autoconf automake libtool"
+ autoconf automake libtool libpri bash"
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
@@ -20,6 +20,11 @@ source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ sed -i 's,freetdm.h,../src/include/freetdm.h,' libs/freetdm/mod_freetdm/mod_freetdm.c
+}
+
build() {
cd "$_builddir"
cp -f "$srcdir/modules.conf" modules.conf || return 1
@@ -97,6 +102,6 @@ conf() {
}
md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
-1f9ed1daf9a1fb910571857c27b933ad modules.conf
+1986cb9499d787b28c8655dd73ebe013 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
aa358c9ca0d8b93fabb6a36a5ed4c469 freeswitch.initd"