summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-03 19:47:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-03 19:47:32 +0000
commit8136831e39f64dac7667d9318ea80ed821a12903 (patch)
tree591d8455f8f6b3797aef9d55431e56a2455ebd5d /main/freeswitch
parentf48632069e0bee30cf4c9a4d2c443900062fc767 (diff)
main/freeswitch: fix for init.d script
fixes #355
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD8
-rwxr-xr-xmain/freeswitch/freeswitch.initd71
2 files changed, 40 insertions, 39 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 860ec0ffe74..6560ffe108f 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=6
+pkgrel=7
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
@@ -14,8 +14,6 @@ source="http://files.freeswitch.org/freeswitch-$pkgver.tar.gz
modules.conf
freeswitch.confd
freeswitch.initd
- freeswitch.post-install
- freeswitch.pre-install
"
build() {
@@ -56,6 +54,4 @@ package(){
md5sums="388effee587887a81fe7f411b7350590 freeswitch-1.0.6.tar.gz
c05f2356be159e99b3845f5260a33599 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-a15f739b6f4f2c1685ab9f8831d30ca6 freeswitch.initd
-107c52398ff88275006b8223ee0b4907 freeswitch.post-install
-25945ad43b7dd988f37bf6f2603e22be freeswitch.pre-install"
+6973e15d72e5876152b160bd9e8d282b freeswitch.initd"
diff --git a/main/freeswitch/freeswitch.initd b/main/freeswitch/freeswitch.initd
index 0538fff56ba..91df7e2acf4 100755
--- a/main/freeswitch/freeswitch.initd
+++ b/main/freeswitch/freeswitch.initd
@@ -4,55 +4,60 @@
# $Header: $
depend() {
- need net
+ need net
}
opts="reload"
+pidfile=/var/run/freeswitch/freeswitch.pid
start() {
- local OPTS
-
- [ -n "${FREESWITCH_USER}" ] && \
- OPTS="${OPTS} -u ${FREESWITCH_USER}"
-
- [ -n "${FREESWITCH_GROUP}" ] && \
- OPTS="${OPTS} -g ${FREESWITCH_GROUP}"
-
- [ -n "${FREESWITCH_OPTS}" ] && \
- OPTS="${OPTS} ${FREESWITCH_OPTS}"
-
- ebegin "Starting Freeswitch"
- limits
- start-stop-daemon --start --quiet --exec /usr/bin/freeswitch \
- -- -nc -conf /etc/freeswitch -log /var/log/freeswitch \
- -run /var/run/freeswitch -db /var/lib/freeswitch/db \
- -htdocs /usr/share/freeswitch/htdocs \
- -scripts /usr/share/freeswitch/scripts ${OPTS}
- eend $?
+ local OPTS
+
+ [ -n "${FREESWITCH_USER}" ] && \
+ OPTS="${OPTS} -u ${FREESWITCH_USER}"
+
+ [ -n "${FREESWITCH_GROUP}" ] && \
+ OPTS="${OPTS} -g ${FREESWITCH_GROUP}"
+
+ [ -n "${FREESWITCH_OPTS}" ] && \
+ OPTS="${OPTS} ${FREESWITCH_OPTS}"
+
+ ebegin "Starting Freeswitch"
+ limits
+ start-stop-daemon --start --quiet --exec /usr/bin/freeswitch \
+ -- \
+ -nc -conf /etc/freeswitch -log /var/log/freeswitch \
+ -run /var/run/freeswitch -db /var/lib/freeswitch/db \
+ -htdocs /usr/share/freeswitch/htdocs \
+ -scripts /usr/share/freeswitch/scripts ${OPTS}
+ eend $?
}
# Recomended ULIMIT settings
# http://tinyurl.com/2dr467l (i,q,u,x not suppoted)
limits() {
- ulimit -c unlimited
- ulimit -d unlimited
- ulimit -f unlimited
- ulimit -n 999999
- ulimit -v unlimited
- ulimit -s 244
- ulimit -l unlimited
+ ulimit -c unlimited
+ ulimit -d unlimited
+ ulimit -f unlimited
+ ulimit -n 999999
+ ulimit -v unlimited
+ ulimit -s 244
+ ulimit -l unlimited
}
stop() {
- ebegin "Stopping Freeswitch"
- /usr/bin/freeswitch -stop
- eend $?
+ ebegin "Stopping Freeswitch"
+ start-stop-daemon --quiet --stop \
+ --pidfile $pidfile \
+ --retry 10 \
+ --exec /usr/bin/freeswitch
+ eend $?
}
reload() {
- start-stop-daemon --stop --signal 1 --quiet --pidfile \
- /var/run/freeswitch.pid --name freeswitch
- return 0
+ start-stop-daemon --stop --signal 1 --quiet \
+ --pidfile $pidfile --name freeswitch
+ return 0
}