aboutsummaryrefslogtreecommitdiffstats
path: root/main/frotz
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-09 08:05:02 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-09 08:05:02 +0000
commitaec70b2daf25291606b8403ca3d44752faeab7b3 (patch)
treed3ac7782dd793283f862f91c131968322ad7cf46 /main/frotz
parent6067060eeae3031505c3ec5e6854b5fc20b2f21f (diff)
main/frotz: use builddir and default prepare
Diffstat (limited to 'main/frotz')
-rw-r--r--main/frotz/APKBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/main/frotz/APKBUILD b/main/frotz/APKBUILD
index ccb94211c3d..a510d800921 100644
--- a/main/frotz/APKBUILD
+++ b/main/frotz/APKBUILD
@@ -14,25 +14,15 @@ install=""
subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/DavidGriffith/${pkgname}/archive/${pkgver}.tar.gz
Makefile.patch"
-
-_builddir="$srcdir/$pkgname-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-${pkgver}"
build() {
- cd "$_builddir"
+ cd "$builddir"
make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
strip $pkgname
install -m755 -d "${pkgdir}/usr/bin"
install -m755 -d "${pkgdir}/usr/share/man/man6"