aboutsummaryrefslogtreecommitdiffstats
path: root/main/gamin
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-01-21 08:09:23 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-21 10:51:49 +0100
commit6bff4b37659cd3ee504aa2d69fd9047a98e1a2e9 (patch)
treefa93119425500deeff49e0898d24977ea9a9a541 /main/gamin
parentf29e250563a6dc9ae93cad1ad138bb4ab0c77781 (diff)
main/gamin: remove
- Python2 only
Diffstat (limited to 'main/gamin')
-rw-r--r--main/gamin/APKBUILD64
-rw-r--r--main/gamin/fix-deprecated-const.patch56
-rw-r--r--main/gamin/fix-pthread-mutex.patch11
3 files changed, 0 insertions, 131 deletions
diff --git a/main/gamin/APKBUILD b/main/gamin/APKBUILD
deleted file mode 100644
index c71ec9db6db..00000000000
--- a/main/gamin/APKBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=gamin
-pkgver=0.1.10
-pkgrel=10
-pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
-url="http://www.gnome.org/~veillard/gamin"
-arch="all"
-license="GPL"
-subpackages="$pkgname-dev py-$pkgname:py"
-depends=
-makedepends="glib-dev python2-dev"
-source="https://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz
- fix-deprecated-const.patch
- fix-pthread-mutex.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-static \
- --with-threads \
- --disable-debug-api \
- --disable-debug \
- --disable-dnotify \
- --libexecdir=/usr/lib/gamin \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- # some kinde of race in the make install which is not solved with -j || return 1
- export MKDIRPROG="mkdir -p"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-py() {
- pkgdesc="Python bindings for the gamin library"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
-}
-
-md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz
-f679aeb48fe9dd376c8828cc9b6941ab fix-deprecated-const.patch
-f05a8d9fe30b6ce2871795c06d74edc4 fix-pthread-mutex.patch"
-sha256sums="28085f0ae8be10eab582ff186af4fb0be92cc6c62b5cc19cd09b295c7c2899a1 gamin-0.1.10.tar.gz
-33af6c9a94b459506fc48892c169d89cb4ad7c68e160f0c4bc74475f19ce5a2f fix-deprecated-const.patch
-bfd5ee42e385367718a4dac8ab318f9a5881ab8b669e4020f87aacaef16a2f8e fix-pthread-mutex.patch"
-sha512sums="21bfe6fcf8fb3117cd5a08c8ce3b8d0d1dd23e478e60a95b76c20d02cc29b050dde086578d81037990484ff891c3e104d2cbbf3d294b4a79346b14a0cae075bb gamin-0.1.10.tar.gz
-c4c10bee70c7231db395cbfe5bdf513ade6be599a11a9d35888ddfaca42d619fe2b5e87c2b2bab469ea98ba718bc01711252313ba5f53c392379b669f5b2902b fix-deprecated-const.patch
-70628fc39521ea8bc4a40b009d0881f6ee540334a31b2f0cb67dde0f75808c69feb78088ad24c3c4a0dec9fa59e87960fd81d1a2e56963ce9268d0a5e14f88e8 fix-pthread-mutex.patch"
diff --git a/main/gamin/fix-deprecated-const.patch b/main/gamin/fix-deprecated-const.patch
deleted file mode 100644
index 3d5f6133fdb..00000000000
--- a/main/gamin/fix-deprecated-const.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Description: Don't use deprecated G_CONST_RETURN. Fixes building with newer glib versions.
-Author: Matthias Klose <doko@ubuntu.com>
-Bug-Ubuntu: https://launchpad.net/bugs/829504
-
-Index: gamin/server/gam_node.c
-===================================================================
---- gamin.orig/server/gam_node.c 2011-10-18 16:09:04.873780685 +0200
-+++ gamin/server/gam_node.c 2011-10-18 16:09:01.965780543 +0200
-@@ -122,7 +122,7 @@
- * it has finished with the string. If it must keep it longer, it
- * should makes its own copy. The returned string must not be freed.
- */
--G_CONST_RETURN char *
-+const char *
- gam_node_get_path(GamNode * node)
- {
- g_assert(node);
-Index: gamin/server/gam_node.h
-===================================================================
---- gamin.orig/server/gam_node.h 2011-10-18 16:09:04.729780677 +0200
-+++ gamin/server/gam_node.h 2011-10-18 16:09:01.961780544 +0200
-@@ -58,7 +58,7 @@
- void gam_node_set_is_dir (GamNode *node,
- gboolean is_dir);
-
--G_CONST_RETURN char *gam_node_get_path (GamNode *node);
-+const char *gam_node_get_path (GamNode *node);
-
- GList *gam_node_get_subscriptions (GamNode *node);
-
-Index: gamin/server/gam_subscription.c
-===================================================================
---- gamin.orig/server/gam_subscription.c 2011-10-18 16:09:04.817780682 +0200
-+++ gamin/server/gam_subscription.c 2011-10-18 16:09:01.965780543 +0200
-@@ -141,7 +141,7 @@
- * @param sub the GamSubscription
- * @returns The path being monitored. It should not be freed.
- */
--G_CONST_RETURN char *
-+const char *
- gam_subscription_get_path(GamSubscription * sub)
- {
- if (sub == NULL)
-Index: gamin/server/gam_subscription.h
-===================================================================
---- gamin.orig/server/gam_subscription.h 2011-10-18 16:09:04.929780687 +0200
-+++ gamin/server/gam_subscription.h 2011-10-18 16:09:01.965780543 +0200
-@@ -21,7 +21,7 @@
-
- int gam_subscription_get_reqno (GamSubscription *sub);
-
--G_CONST_RETURN char *gam_subscription_get_path (GamSubscription *sub);
-+const char *gam_subscription_get_path (GamSubscription *sub);
-
- GamListener *gam_subscription_get_listener (GamSubscription *sub);
-
diff --git a/main/gamin/fix-pthread-mutex.patch b/main/gamin/fix-pthread-mutex.patch
deleted file mode 100644
index c8c5b0005ca..00000000000
--- a/main/gamin/fix-pthread-mutex.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- gamin-0.1.10.orig/libgamin/gam_data.c
-+++ gamin-0.1.10/libgamin/gam_data.c
-@@ -470,7 +470,7 @@
- }
- if (is_threaded > 0) {
- pthread_mutexattr_init(&attr);
--#if defined(linux) || defined(PTHREAD_MUTEX_RECURSIVE_NP)
-+#if defined(linux) && defined(PTHREAD_MUTEX_RECURSIVE_NP)
- pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE_NP);
- #else
- pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);