aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-04 07:56:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-04 07:56:13 +0000
commit80f826f2729b549aba219c6947164b2e96956a03 (patch)
tree83beb9999225ab3d4eb20cc5ef3926f9e6823b23 /main/gcc/APKBUILD
parent9306e57a5d5d9539c241a84437365c2a5b9dc0ad (diff)
main/gcc: build with NPTL support
we need set dynamic-linker to point on other ld-uClibc
Diffstat (limited to 'main/gcc/APKBUILD')
-rw-r--r--main/gcc/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 7ab9918c1b4..436636740dc 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -4,6 +4,8 @@ pkgver=4.4.3
_pv=4.4.2
_specsver=0.1.7
_espfver=0.3.6
+_uclibc_abiver=0.9.32
+
pkgrel=0
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
@@ -18,6 +20,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-core-$pkgver.tar.bz2
gcc-spec-env.patch
pt_gnu_eh_frame.patch
uclibc-getipinfo.patch
+ gcc-dynamic-linker.patch
"
# ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-objc-$pkgver.tar.bz2
build ()
@@ -52,7 +55,6 @@ build ()
--disable-libstdcxx-pch \
--disable-multilib \
--disable-nls \
- --disable-threads \
--disable-werror \
--enable-__cxa_atexit \
--enable-cld \
@@ -61,7 +63,10 @@ build ()
--enable-shared \
--enable-target-optspace \
--enable-tls \
+ --enable-threads \
--with-arch=i486 \
+ --with-dynamic-linker=ld-uClibc.so.$_uclibc_abiver \
+ --with-dynamic-linker-prefix=/lib \
--with-system-zlib \
--without-system-libunwind
@@ -127,4 +132,5 @@ cd179ec4f05ee17ce76464da25a2674c gcc-g++-4.4.3.tar.bz2
528926b586b2591474b6c2a7ef8ee6d7 gcc-4.4.2-specs-0.1.7.tar.bz2
c4045bfa85d8be780affd465be9d8ca8 gcc-spec-env.patch
2db1e3482c5dd59dab70f701afa2ca80 pt_gnu_eh_frame.patch
-6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch"
+6cc2385c5bbd6d0da6eaedd53c8bf547 uclibc-getipinfo.patch
+6db5c87887beee75cde3cce86625b9ed gcc-dynamic-linker.patch"