aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc/APKBUILD
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-08-21 03:07:26 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-08-21 03:07:26 -0600
commit830c0d10ac59fb40e3552b54af8c29d7c58a569b (patch)
treedc065e56c06d4f72bc7e3fbe12e93cabae6d9c6f /main/gcc/APKBUILD
parent4941197042bc2f91ad07e83a482e7f3351860064 (diff)
main/gcc: use -O2 for building gcc
Diffstat (limited to 'main/gcc/APKBUILD')
-rw-r--r--main/gcc/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 51bb8e47f90..d87e20446a7 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -6,7 +6,7 @@ pkgver=10.2.0
[ "$CHOST" != "$CTARGET" ] && _target="-$CTARGET_ARCH" || _target=""
pkgname="$pkgname$_target"
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="https://gcc.gnu.org"
arch="all"
@@ -280,6 +280,8 @@ build() {
echo " hash_style_configure=$_hash_style_configure"
echo ""
+ export CFLAGS="$CFLAGS -O2"
+
mkdir -p "$_builddir"
cd "$_builddir"
"$_gccdir"/configure --prefix=/usr \