aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc/APKBUILD
diff options
context:
space:
mode:
authorAriadne Conill <ariadne@dereferenced.org>2020-06-24 08:32:52 -0600
committerAriadne Conill <ariadne@dereferenced.org>2020-06-24 08:33:13 -0600
commitbbe9701ace6c22d386ea2d3340993c0321763d04 (patch)
tree0c5f00e63bdd42df377e78b01da1dd384acf0c0b /main/gcc/APKBUILD
parentce80dcf368f2c5a43459d9091ace444304c04b88 (diff)
main/gcc: fix bootstrap
Diffstat (limited to 'main/gcc/APKBUILD')
-rw-r--r--main/gcc/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 1f97eba0724..d1c028ed52f 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -441,9 +441,11 @@ libcxx() {
pkgdesc="GNU C++ standard runtime library"
depends=
- # verify that we are using clock_gettime rather than doing direct syscalls
- # so we dont break 32 bit arches due to time64.
- nm -D "$pkgdir"/usr/lib/libstdc++.so.* | grep clock_gettime
+ if [ "$CHOST" = "$CTARGET" ]; then
+ # verify that we are using clock_gettime rather than doing direct syscalls
+ # so we dont break 32 bit arches due to time64.
+ nm -D "$pkgdir"/usr/lib/libstdc++.so.* | grep clock_gettime
+ fi
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/${_target:+$CTARGET/}lib/libstdc++.so.* "$subpkgdir"/usr/lib/