aboutsummaryrefslogtreecommitdiffstats
path: root/main/gdb/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-02-12 17:12:09 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-02-12 17:24:18 +0100
commit8543a8ad2daf6c73a1e7870d69c93f78a2a68c66 (patch)
tree96ef4d1005b0bea018a42b48f85e3fe0c3f1a7be /main/gdb/APKBUILD
parent4ed9f3ce77976bc9f5b29e424522febb0d330830 (diff)
main/gdb: improve APKBUILD
And fix building of man pages by depending on perl-dev since perl-dev includes pod2man nowadays.
Diffstat (limited to 'main/gdb/APKBUILD')
-rw-r--r--main/gdb/APKBUILD27
1 files changed, 7 insertions, 20 deletions
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index 38ff6625999..8ad1c7fe02a 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,33 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
pkgver=7.12.1
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Debugger"
-url="http://sources.redhat.com/gdb/"
+url="https://www.sourceware.org/gdb/"
arch="all"
license="GPL3"
depends=
makedepends="ncurses-dev expat-dev texinfo readline-dev python2-dev
- zlib-dev autoconf automake libtool linux-headers"
+ zlib-dev autoconf automake libtool linux-headers perl-dev"
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch)
- msg "Applying $i"
- patch -p1 -i "$srcdir"/$i || return 1
- ;;
- esac
- done
-}
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
build () {
- cd "$_builddir"
+ cd "$builddir"
local _config="
--build=$CBUILD
--host=$CHOST
@@ -54,7 +41,7 @@ build () {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
# resolve conflict with binutils-doc