aboutsummaryrefslogtreecommitdiffstats
path: root/main/gegl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-09-29 07:25:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-09-29 07:28:20 +0000
commit95aeab4994065e6a26f794032b9d46ae32fc612a (patch)
treeb13c5bd7ac47cfb962ab08e1db26c6b79cc5304d /main/gegl
parent4dde5d5a86737f9d7f5ce23bd022dc60dc81d527 (diff)
community/gegl: move from main
Diffstat (limited to 'main/gegl')
-rw-r--r--main/gegl/APKBUILD46
-rw-r--r--main/gegl/gegl-uclibc.patch22
2 files changed, 0 insertions, 68 deletions
diff --git a/main/gegl/APKBUILD b/main/gegl/APKBUILD
deleted file mode 100644
index e3852295d89..00000000000
--- a/main/gegl/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=gegl
-pkgver=0.2.0
-pkgrel=5
-pkgdesc="Graph based image processing framework"
-url="http://www.gegl.org/"
-arch="all"
-license="GPL3 LGPL3"
-makedepends="babl-dev libpng-dev libjpeg-turbo-dev gtk+-dev librsvg-dev
- lua5.1-dev jasper-dev exiv2-dev"
-subpackages="$pkgname-dev $pkgname-lang"
-source="http://ftp.gimp.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
- "
-
-depends_dev="babl-dev glib-dev"
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir/$i" || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-docs \
- --with-exiv2 \
- --with-jasper \
- --with-librsvg \
- --with-lua \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-sha512sums="16ef3f6852fd8efef2b6468a754342a2d003f2c2bef468d9465a448e6c89dedb8e791570f073a9faed05218a7c94c6c418eaa0f3abeadfb3e6b88d766ab792c8 gegl-0.2.0.tar.bz2"
diff --git a/main/gegl/gegl-uclibc.patch b/main/gegl/gegl-uclibc.patch
deleted file mode 100644
index cb93f0fec75..00000000000
--- a/main/gegl/gegl-uclibc.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./gegl/buffer/gegl-buffer.c.orig
-+++ ./gegl/buffer/gegl-buffer.c
-@@ -80,7 +80,7 @@
- /* #define GEGL_BUFFER_DEBUG_ALLOCATIONS to print allocation stack
- * traces for leaked GeglBuffers using GNU C libs backtrace_symbols()
- */
--#ifndef G_OS_WIN32
-+#if !defined(G_OS_WIN32) && !defined(__UCLIBC__)
- #include <execinfo.h>
- #endif
-
-@@ -876,8 +876,8 @@
- gegl_buffer_get_alloc_stack (void)
- {
- char *result = NULL;
--#ifdef G_OS_WIN32
-- result = g_strdup ("backtrack not available on win32\n");
-+#if defined(G_OS_WIN32) || defined(__UCLIBC__)
-+ result = g_strdup ("backtrack not available\n");
- #else
- void *functions[MAX_N_FUNCTIONS];
- int n_functions = 0;