aboutsummaryrefslogtreecommitdiffstats
path: root/main/glm/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-12-28 14:52:26 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-12-28 14:53:31 +0000
commitc464b220306815d1dbb133a32139005fd2dd831a (patch)
treeb8d9b73bae63d5f1d833ddc9a5eab9ceec159d2a /main/glm/APKBUILD
parent03b6aa6c33a0bdbdf86ee88214b45c4e73942809 (diff)
main/glm: upgrade to 0.9.9.3 and add check()
Diffstat (limited to 'main/glm/APKBUILD')
-rw-r--r--main/glm/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/glm/APKBUILD b/main/glm/APKBUILD
index 8c70c9cdacb..d9a63c39737 100644
--- a/main/glm/APKBUILD
+++ b/main/glm/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glm
-pkgver=0.9.9.2
+pkgver=0.9.9.3
pkgrel=0
pkgdesc="C++ mathematics library for graphics programming"
url="http://glm.g-truc.net/"
@@ -9,7 +9,6 @@ license="MIT"
makedepends="cmake"
subpackages="$pkgname-dev"
source="https://github.com/g-truc/glm/releases/download/$pkgver/glm-$pkgver.zip"
-options="!check" # the testsuite included in cmake in function build
builddir="$srcdir/$pkgname"
build() {
@@ -24,9 +23,14 @@ build() {
make
}
+check() {
+ cd "$builddir"/build
+ make test
+}
+
package() {
cd "$builddir"/build
make install DESTDIR="$pkgdir"
}
-sha512sums="f50059118d907f7e7fa06f0c38dff15aa0cdec61b3ff0059b927d100ce9891f3c1aa3e2c120555891c096b428868006aa5e35c4f82d57198382f3a94240ee9f9 glm-0.9.9.2.zip"
+sha512sums="eb7589345eb627d9fda84771bd2cf3eb0e4e9e48bf6bb7490bd8844b66558717de5dc96cde9d66e81f7ba4e54090f18dbe1bbccb2452ed0ed8c17cdf7b6e4aa2 glm-0.9.9.3.zip"