aboutsummaryrefslogtreecommitdiffstats
path: root/main/gmp5/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-08 10:12:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-08 11:40:50 +0000
commit7e1a0290e1a825ae072b9ce5c3ea7b5e03cab8c9 (patch)
treedddca535320d1c2aaea500be760f13c6a82ea64c /main/gmp5/APKBUILD
parent4cfcfce44e0a30aadea101c76ab5b609317ced9c (diff)
main/gmp5: support crosscompiling and cleanups
* put patches to prepare() hook * delete --enable-mpbsd as it no longer exists
Diffstat (limited to 'main/gmp5/APKBUILD')
-rw-r--r--main/gmp5/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/gmp5/APKBUILD b/main/gmp5/APKBUILD
index 7e7052cb2de..f57a04f6573 100644
--- a/main/gmp5/APKBUILD
+++ b/main/gmp5/APKBUILD
@@ -16,17 +16,21 @@ source="ftp://ftp.gnu.org/gnu/gmp/gmp-$pkgver.tar.bz2
"
_builddir="$srcdir"/$_name-$pkgver
-build() {
+
+prepare() {
cd "$_builddir"
patch -p1 < "$srcdir"/gmp-4.1.4-noexecstack.patch || return 1
+}
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--build=${CBUILD} \
--host=${CHOST} \
+ --with-sysroot=${CBUILDROOT} \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
--localstatedir=/var/state/gmp \
- --enable-mpbsd \
--enable-cxx \
--with-pic \
|| return 1