aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnuchess
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-18 08:28:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-18 10:57:49 +0000
commit8f07e7d5f8f9f4b71d2d9ed087b6591065c143b6 (patch)
tree37fd7c275d3bb5ee0e86e74f76fcdf02e027fd4d /main/gnuchess
parent785826a33b8946043df64e81a7611186f0c34fa6 (diff)
main/gnuchess: upgrade to 6.1.0
Diffstat (limited to 'main/gnuchess')
-rw-r--r--main/gnuchess/APKBUILD16
-rw-r--r--main/gnuchess/uclibc.patch14
2 files changed, 24 insertions, 6 deletions
diff --git a/main/gnuchess/APKBUILD b/main/gnuchess/APKBUILD
index 3708da77d27..af359398441 100644
--- a/main/gnuchess/APKBUILD
+++ b/main/gnuchess/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnuchess
-pkgver=6.0.3
+pkgver=6.1.0
pkgrel=0
pkgdesc="The GNU chess program"
url="http://www.gnu.org/software/chess/"
@@ -11,13 +11,14 @@ depends=
makedepends=
install=""
subpackages="$pkgname-doc"
-source="ftp://ftp.gnu.org/pub/gnu/chess/gnuchess-$pkgver.tar.gz"
+source="ftp://ftp.gnu.org/pub/gnu/chess/gnuchess-$pkgver.tar.gz
+ uclibc.patch
+ "
_builddir="$srcdir"/gnuchess-$pkgver
prepare() {
local i
cd "$_builddir"
- update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -44,6 +45,9 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="28625afb8f48b86211ee1d217c308064 gnuchess-6.0.3.tar.gz"
-sha256sums="7c3a99c6c62f5dcc12c6fded9e91577ba2d327668b13b1af6169cc8b1a46ce05 gnuchess-6.0.3.tar.gz"
-sha512sums="8f41108847a5c3ce63c824b2d0b29e5e47caa9561bc683565992dc0659c00e863d61be8f0ffbc7c6231d53c06cf7b4f0f6c29016ba6a6da535c1b408e43ef85b gnuchess-6.0.3.tar.gz"
+md5sums="41b0771cee225eff9563d42e7f93263c gnuchess-6.1.0.tar.gz
+9687f03c258f38644ed64f944a40c704 uclibc.patch"
+sha256sums="9501e6bceef22bdbdbdb3fc71c9745ebc125a06fdafacb270bb2c29b15c6379b gnuchess-6.1.0.tar.gz
+9789daa44ff63392ed1051c1c71ae5592f694731e500860684953acf97cfe9a1 uclibc.patch"
+sha512sums="d61822fd2920e5d891f43caffdf54673be2cc3bed9d726c78a0f91d0c2130e0ea26af39954f59fb33054e3907118ebe89025014cf8e880b2a2cc087a79d55c49 gnuchess-6.1.0.tar.gz
+3f42fdcccfeab43f2e47ae599aee19a76a9e4b6af41f68456d30d8520fb410c689f2d56aae06c0588bea9b38e5aa508fb992cfc913906b6e5911d7f9d60bd9fc uclibc.patch"
diff --git a/main/gnuchess/uclibc.patch b/main/gnuchess/uclibc.patch
new file mode 100644
index 00000000000..53721da3d74
--- /dev/null
+++ b/main/gnuchess/uclibc.patch
@@ -0,0 +1,14 @@
+--- ./lib/gettext.h.orig 2013-11-18 08:27:03.257572285 +0000
++++ ./lib/gettext.h 2013-11-18 08:28:02.271566431 +0000
+@@ -50,9 +50,9 @@
+ /* Many header files from the libstdc++ coming with g++ 3.3 or newer include
+ <libintl.h>, which chokes if dcgettext is defined as a macro. So include
+ it now, to make later inclusions of <libintl.h> a NOP. */
+-#if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3)
++#if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3) && !defined (__UCLIBC__)
+ # include <cstdlib>
+-# if (__GLIBC__ >= 2 && !defined __UCLIBC__) || _GLIBCXX_HAVE_LIBINTL_H
++# if (__GLIBC__ >= 2) || _GLIBCXX_HAVE_LIBINTL_H
+ # include <libintl.h>
+ # endif
+ #endif