aboutsummaryrefslogtreecommitdiffstats
path: root/main/go/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2015-09-07 01:27:55 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2015-09-09 07:44:16 +0000
commit5d424be11444e6e99710e49295c2c831d3a460fa (patch)
tree7d625b07921499e7ab18c2a3d26f86cdb62d963a /main/go/APKBUILD
parentf0cd3fa512b13e3dba57c9cfa8afb653637bd459 (diff)
main/go: make go work with latest go-bootstrap change
Also install go and gofmt binary to /usr/lib/go/bin and symlink it to /usr/bin. Also fix removal of tests.
Diffstat (limited to 'main/go/APKBUILD')
-rw-r--r--main/go/APKBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/main/go/APKBUILD b/main/go/APKBUILD
index a0c4b6063b3..5fdd6120835 100644
--- a/main/go/APKBUILD
+++ b/main/go/APKBUILD
@@ -4,12 +4,11 @@ pkgname=go
pkgver=1.5
# This should be the latest commit on the corresponding release branch
_toolsver="d02228d1857b9f49cd0252788516ff5584266eb6"
-pkgrel=0
+pkgrel=1
pkgdesc="Go programming language compiler"
url="http://www.golang.org/"
arch="x86_64 armhf"
license="BSD"
-replaces="go-bootstrap"
depends=""
depends_dev=""
makedepends="bash go-bootstrap"
@@ -32,7 +31,7 @@ build() {
export GOROOT="$_builddir"
export GOBIN="$GOROOT"/bin
export GOROOT_FINAL=/usr/lib/go
- export GOROOT_BOOTSTRAP=/usr/lib/go
+ export GOROOT_BOOTSTRAP=/usr/lib/go-bootstrap
case "$CARCH" in
x86) export GOARCH="386" ;;
@@ -64,8 +63,10 @@ package() {
cd "$_builddir"
mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/go "$pkgdir"/usr/share/doc/go
- install -Dm755 bin/go "$pkgdir"/usr/bin || return 1
- install -Dm755 bin/gofmt "$pkgdir"/usr/bin || return 1
+ for binary in go gofmt; do
+ install -Dm755 bin/$binary "$pkgdir"/usr/lib/go/bin/$binary || return 1
+ ln -s /usr/lib/go/bin/$binary "$pkgdir"/usr/bin/$binary || return 1
+ done
# The source needs to be installed due to an upstream
# bug (https://github.com/golang/go/issues/2775).
@@ -76,8 +77,15 @@ package() {
# Remove tests from /usr/lib/go/src.
# Those shouldn't be affacted by the upstream bug (see above).
- find "$pkgdir"/usr/lib/go \( -type f -a -iname '*_test*' \) \
- -o \( -type d -name 'testdata' \) -exec rm -rf \{\} \+
+ find "$pkgdir"/usr/lib/go/src \( -type f -a -name "*_test.go" \) \
+ -exec rm -rf \{\} \+ || return 1
+ find "$pkgdir"/usr/lib/go/src \( -type d -a -name "testdata" \) \
+ -exec rm -rf \{\} \+ || return 1
+ find "$pkgdir"/usr/lib/go/src \( -type f -a -name "*.bash" \) \
+ -exec rm -rf \{\} \+ || return 1
+
+ # Remove bootstrap files.
+ rm -rf "$pkgdir"/usr/lib/go/pkg/bootstrap
}
tools() {