aboutsummaryrefslogtreecommitdiffstats
path: root/main/gparted/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-06-30 11:43:43 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-06-30 13:04:28 +0200
commit5204b218787b2eeff641c0e40eb029a6e56b40c5 (patch)
treef2f254cedaedba5589e4de2ad4e0dfd529a933ee /main/gparted/APKBUILD
parent95566f972455cbdd8af72554eef97e20da8a9536 (diff)
main/gparted: fix sscanf use and add ntfs-3g-progs as dep
the sscanf modifier %Ld is invalid. use %lld instead https://bugzilla.gnome.org/show_bug.cgi?id=768239
Diffstat (limited to 'main/gparted/APKBUILD')
-rw-r--r--main/gparted/APKBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/main/gparted/APKBUILD b/main/gparted/APKBUILD
index 091f553402d..4d874a62592 100644
--- a/main/gparted/APKBUILD
+++ b/main/gparted/APKBUILD
@@ -1,26 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gparted
pkgver=0.26.1
-pkgrel=0
+pkgrel=1
pkgdesc="a graphical partition editor for creating, reorganizing, and deleting disk partitions"
url="http://gparted.sourceforge.net/"
arch="all"
license="GPL"
-depends="e2fsprogs"
+depends="e2fsprogs ntfs-3g-progs"
makedepends="gtkmm-dev parted-dev util-linux-dev"
install=
subpackages="$pkgname-doc $pkgname-lang"
-source="http://downloads.sourceforge.net/gparted/gparted-$pkgver/gparted-$pkgver.tar.gz"
-source="http://downloads.sourceforge.net/project/gparted/gparted/gparted-$pkgver/gparted-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/project/gparted/gparted/gparted-$pkgver/gparted-$pkgver.tar.gz
+ musl-fix-sscanf.patch
+ "
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,10 +32,13 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="b9c5f6b5ffd37400bd4bf5929e9b1781 gparted-0.26.1.tar.gz"
-sha256sums="2f54b642d25aef5ccdd9f06671c16350c005834df5c3eb13a9b7f33246372dc1 gparted-0.26.1.tar.gz"
-sha512sums="cba792751f8e984cbb4e1e0baaa97d0022ba47bd400312734ed5ae4a1bea07bc46ed522ca19a84b74ad503387fc9bd9d9cd85cdd647ba2ec028b39f8da502b67 gparted-0.26.1.tar.gz"
+md5sums="b9c5f6b5ffd37400bd4bf5929e9b1781 gparted-0.26.1.tar.gz
+c8a5842bf213ef02eeb85d95e3237372 musl-fix-sscanf.patch"
+sha256sums="2f54b642d25aef5ccdd9f06671c16350c005834df5c3eb13a9b7f33246372dc1 gparted-0.26.1.tar.gz
+427c07a7b15deacaec7754960d883da8811b82272dd655cad27c6071269e8822 musl-fix-sscanf.patch"
+sha512sums="cba792751f8e984cbb4e1e0baaa97d0022ba47bd400312734ed5ae4a1bea07bc46ed522ca19a84b74ad503387fc9bd9d9cd85cdd647ba2ec028b39f8da502b67 gparted-0.26.1.tar.gz
+aaa3f771e100d89c756c63e206090ada1c316b6028cb4ca79142a82fab7a29b54ac7229e06098eb5265bce32219a2df28f9f79c11d60d0f41ee9e538bb1f8641 musl-fix-sscanf.patch"