aboutsummaryrefslogtreecommitdiffstats
path: root/main/graphite2/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-07 13:58:58 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-10 02:41:37 +0000
commit210b3f7f39bf6b27b8c5a6f9bacd5615316dbee1 (patch)
treeea8f5d690add49e8d36fdac6c6a04d90c5467ed1 /main/graphite2/APKBUILD
parent38d3834831794f40478eda936ebf39261fb0b21b (diff)
main/graphite2: modernise, mark tests broken, fix license
Diffstat (limited to 'main/graphite2/APKBUILD')
-rw-r--r--main/graphite2/APKBUILD26
1 files changed, 9 insertions, 17 deletions
diff --git a/main/graphite2/APKBUILD b/main/graphite2/APKBUILD
index 33ee7f52ec7..faf502a4b1e 100644
--- a/main/graphite2/APKBUILD
+++ b/main/graphite2/APKBUILD
@@ -3,14 +3,15 @@
pkgname=graphite2
_realname=${pkgname/2/}
pkgver=1.3.10
-pkgrel=0
+pkgrel=1
pkgdesc="reimplementation of the SIL Graphite text processing engine"
url="http://graphite.sil.org/"
arch="all"
-license="LGPL"
+options="!check" # Test suite requires Graphite 1 and py2-fonttools
+license="LGPL-2.1+ OR MPL-2.0+ OR GPL-2.0+"
depends=""
depends_dev="freetype-dev"
-makedepends="$depends_dev python2 cmake"
+makedepends="$depends_dev cmake"
install=""
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$pkgver.tar.gz
@@ -18,19 +19,10 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/silnrsi/$_realname/archive/$
graphite2-1.2.0-cmakepath.patch
"
-_builddir="$srcdir"/$_realname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_realname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
mkdir build && cd build
cmake -G "Unix Makefiles" .. \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
@@ -38,15 +30,15 @@ build() {
-DCMAKE_BUILD_TYPE:STRING=Release \
-DGRAPHITE2_COMPARE_RENDERER=OFF \
-DGRAPHITE2_NFILEFACE=ON \
- -DGRAPHITE2_NSEGCACHE=ON || return 1
+ -DGRAPHITE2_NSEGCACHE=ON
# fix unwanted -O3 cflag (taken form Debian)
find . -type f ! -name "rules" ! -name "changelog" -exec sed -i -e 's/\-O3//g' {} \;
- make || return 1
+ make
}
package() {
- cd "$_builddir"/build
+ cd "$builddir"/build
make DESTDIR="$pkgdir/" install
}