summaryrefslogtreecommitdiffstats
path: root/main/gtk-doc/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/gtk-doc/APKBUILD
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
merged x11 repository into main
ref #255
Diffstat (limited to 'main/gtk-doc/APKBUILD')
-rw-r--r--main/gtk-doc/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/gtk-doc/APKBUILD b/main/gtk-doc/APKBUILD
new file mode 100644
index 00000000000..9c86f49ccf1
--- /dev/null
+++ b/main/gtk-doc/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gtk-doc
+pkgver=1.13
+pkgrel=0
+pkgdesc="Documentation tool for public library API"
+url="http://www.gtk.org/gtk-doc/"
+license="GPL FDL"
+depends="docbook-xsl gnome-doc-utils perl pkgconfig"
+makedepends="rarian-dev"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="27940d6cd5c9dcda8fc003043d8c299a gtk-doc-1.13.tar.bz2"