aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtkspell/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-07 15:12:32 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-10 02:42:21 +0000
commitb3b6f601097e624447dd5ab41dbdd4c95076cdb6 (patch)
tree71c4c58f9a968c5a6facc34dbfeea785261d2e71 /main/gtkspell/APKBUILD
parent3704cbf44d3cbcbc4eb621fffae8712e48f51035 (diff)
main/gtkspell: modernise, add tests, fix license
No license header in source code, and COPYING is GPL-2.0. A message dated 2011[1] on the mailing lists states that it is GPL-2.0-only, not GPL-2.0+. [1]: https://sourceforge.net/p/gtkspell/mailman/message/27291338/
Diffstat (limited to 'main/gtkspell/APKBUILD')
-rw-r--r--main/gtkspell/APKBUILD31
1 files changed, 16 insertions, 15 deletions
diff --git a/main/gtkspell/APKBUILD b/main/gtkspell/APKBUILD
index 849ba1d492d..13647cc56a1 100644
--- a/main/gtkspell/APKBUILD
+++ b/main/gtkspell/APKBUILD
@@ -1,37 +1,38 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtkspell
pkgver=2.0.16
-pkgrel=6
+pkgrel=7
pkgdesc="GtkSpell provides word-processor-style highlighting and replacement of misspelled words in a GtkTextView widget"
url="http://gtkspell.sourceforge.net/"
arch="all"
-license="GPL"
-depends_dev="gtk+2.0-dev"
-makedepends="$depends_dev enchant-dev intltool"
+license="GPL-2.0-only"
+makedepends="gtk+2.0-dev enchant-dev intltool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://$pkgname.sourceforge.net/download/$pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d gtkspell-2.0.16.tar.gz"