aboutsummaryrefslogtreecommitdiffstats
path: root/main/guile/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-09-07 18:29:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-09-07 18:29:54 +0000
commiteecc871f8ac20711406bbdd46db60b38e9874cbd (patch)
tree8db97382f33bdd562a8b584b2cc7caa8e92c7764 /main/guile/APKBUILD
parent780c9ac71d85d5b5e7654cd8b5622d47195a7e4e (diff)
main/guile: new aport
Guile is a portable, embeddable Scheme implementation written in C http://www.gnu.org/software/guile/
Diffstat (limited to 'main/guile/APKBUILD')
-rw-r--r--main/guile/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/guile/APKBUILD b/main/guile/APKBUILD
new file mode 100644
index 00000000000..2a7609e0d68
--- /dev/null
+++ b/main/guile/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=guile
+pkgver=1.8.7
+pkgrel=0
+pkgdesc="Guile is a portable, embeddable Scheme implementation written in C"
+url="http://www.gnu.org/software/guile/"
+license="GPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gmp-dev libtool ncurses-dev texinfo"
+depends=
+install=
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-error-on-warning || return 1
+ make LDFLAGS+="-lpthread" || return 1
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="991b5b3efcbbc3f7507d05bc42f80a5e guile-1.8.7.tar.gz"