summaryrefslogtreecommitdiffstats
path: root/main/haserl/lua2c.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-01-10 10:28:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-10 10:28:10 +0000
commit4703bb89a30ec2e40c740509a3f827c0a961715c (patch)
tree0f2ae2d524fc9da21c14b1c6ef453c855fc1a614 /main/haserl/lua2c.patch
parentd511fa45fd11037d868a358876cb3c918143b958 (diff)
main/haserl: fix for x86_64
Force rebuild of haserl_lualib.inc fixes #513
Diffstat (limited to 'main/haserl/lua2c.patch')
-rw-r--r--main/haserl/lua2c.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/main/haserl/lua2c.patch b/main/haserl/lua2c.patch
new file mode 100644
index 00000000000..9bfba3173e3
--- /dev/null
+++ b/main/haserl/lua2c.patch
@@ -0,0 +1,56 @@
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (revision 176)
++++ src/Makefile.am (working copy)
+@@ -19,24 +19,17 @@
+ endif
+
+ if USE_LUA
++lua2c_LIBS ?= -llua -ldl -lm
++lua2c_LDFLAGS ?= -Wl,-E
++lua2c: lua2c.c
++ $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(lua2c_LDFLAGS) \
++ -o $@ $^ $(lua2c_LIBS)
+
+-haserl_lualib.inc : haserl_lualib.lua
+- @echo '-----------------------------------------------------'
+- @echo 'Whoops. haserl_lualib.inc is old. You will need'
+- @echo 'to compile lua2c by hand, or help the maintainer'
+- @echo 'get automake to do it for you.'
+- @echo ''
+- @echo 'For now, to compile lua2c:'
+- @echo ''
+- @echo 'gcc -I<luaheaderdir> -Wl,-E -L<lualibdir> -o lua2c lua2c.c -llua -ldl -lm'
+- @echo ''
+- @echo ''
+- @echo 'Then follow the instructions in lua2c.c to create a'
+- @echo 'new haserl_lualib.inc'
+- @echo ''
+- @echo 'Sorry.'
+- @echo '-----------------------------------------------------'
+- @exit 1
++haserl_lualib.inc : haserl_lualib.lua lua2c
++ if ! ./lua2c haserl_lualib haserl_lualib.lua >$@; then \
++ rm $@; \
++ exit 1 ;\
++ fi
+
+ h_lua_common.c : haserl_lualib.inc
+
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 176)
++++ configure.ac (working copy)
+@@ -7,6 +7,12 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+
++# allow differnt compiler for build tools in case cross compiling
++if test -z "$CC_FOR_BUILD"; then
++ CC_FOR_BUILD="$CC"
++fi
++AC_SUBST(CC_FOR_BUILD)
++
+ # Checks for libraries.
+
+ # Checks for header files.