summaryrefslogtreecommitdiffstats
path: root/main/haserl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-05-27 18:36:10 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-05-27 18:36:10 +0300
commit07afc56944054b161e1916b0ea6c2b0fa7e13d4d (patch)
tree31aeffc3d41e076690308d0ea61f37dcffc226db /main/haserl
parente3206064c6394c0e776d404750b45fff599aa5f7 (diff)
main/haserl: upgrade to 0.9.29
remove patch applied upstream.
Diffstat (limited to 'main/haserl')
-rw-r--r--main/haserl/APKBUILD9
-rw-r--r--main/haserl/lua2c.patch56
2 files changed, 3 insertions, 62 deletions
diff --git a/main/haserl/APKBUILD b/main/haserl/APKBUILD
index b6e644aef6d..e58045d8913 100644
--- a/main/haserl/APKBUILD
+++ b/main/haserl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=haserl
-pkgver=0.9.27
-pkgrel=1
+pkgver=0.9.29
+pkgrel=0
pkgdesc="Html And Shell Embedded Report Language"
url="http://haserl.sourceforge.net/"
arch="all"
@@ -10,13 +10,11 @@ depends=
makedepends="lua-dev automake autoconf"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- lua2c.patch
"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
- patch -p0 -i "$srcdir"/lua2c.patch || return 1
sed -i -e 's/^ /\t/' src/Makefile.am || return 1
rm -f src/haserl_lualib.inc
@@ -36,5 +34,4 @@ package() {
chmod 4111 "$pkgdir"/usr/bin/haserl
}
-md5sums="1f692db8939858338a44e25d0190aa9e haserl-0.9.27.tar.gz
-00a612705c8a75e0d991749bf9f11e24 lua2c.patch"
+md5sums="4cac9409530200b4a7a82a48ec174800 haserl-0.9.29.tar.gz"
diff --git a/main/haserl/lua2c.patch b/main/haserl/lua2c.patch
deleted file mode 100644
index 9bfba3173e3..00000000000
--- a/main/haserl/lua2c.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Index: src/Makefile.am
-===================================================================
---- src/Makefile.am (revision 176)
-+++ src/Makefile.am (working copy)
-@@ -19,24 +19,17 @@
- endif
-
- if USE_LUA
-+lua2c_LIBS ?= -llua -ldl -lm
-+lua2c_LDFLAGS ?= -Wl,-E
-+lua2c: lua2c.c
-+ $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) $(lua2c_LDFLAGS) \
-+ -o $@ $^ $(lua2c_LIBS)
-
--haserl_lualib.inc : haserl_lualib.lua
-- @echo '-----------------------------------------------------'
-- @echo 'Whoops. haserl_lualib.inc is old. You will need'
-- @echo 'to compile lua2c by hand, or help the maintainer'
-- @echo 'get automake to do it for you.'
-- @echo ''
-- @echo 'For now, to compile lua2c:'
-- @echo ''
-- @echo 'gcc -I<luaheaderdir> -Wl,-E -L<lualibdir> -o lua2c lua2c.c -llua -ldl -lm'
-- @echo ''
-- @echo ''
-- @echo 'Then follow the instructions in lua2c.c to create a'
-- @echo 'new haserl_lualib.inc'
-- @echo ''
-- @echo 'Sorry.'
-- @echo '-----------------------------------------------------'
-- @exit 1
-+haserl_lualib.inc : haserl_lualib.lua lua2c
-+ if ! ./lua2c haserl_lualib haserl_lualib.lua >$@; then \
-+ rm $@; \
-+ exit 1 ;\
-+ fi
-
- h_lua_common.c : haserl_lualib.inc
-
-Index: configure.ac
-===================================================================
---- configure.ac (revision 176)
-+++ configure.ac (working copy)
-@@ -7,6 +7,12 @@
- AC_PROG_INSTALL
- AC_PROG_LN_S
-
-+# allow differnt compiler for build tools in case cross compiling
-+if test -z "$CC_FOR_BUILD"; then
-+ CC_FOR_BUILD="$CC"
-+fi
-+AC_SUBST(CC_FOR_BUILD)
-+
- # Checks for libraries.
-
- # Checks for header files.